disable pulseaudio in SeaMonkey

RESOLVED FIXED in seamonkey2.27

Status

defect
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

Trunk
seamonkey2.27
x86
Linux

SeaMonkey Tracking Flags

(seamonkey2.25 fixed, seamonkey2.26 fixed, seamonkey2.27 fixed)

Details

Attachments

(2 attachments)

checking for libpulse... Package libpulse was not found in the pkg-config search path.
Perhaps you should add the directory containing `libpulse.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libpulse' found
configure: error: pulseaudio audio backend requires libpulse development package
------ config.log ------
/usr/include/linux/ethtool.h:66:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:74:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:83:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:179:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:201:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:226:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:239:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:248:2: error: expected specifier-qualifier-list before '__u32'
/usr/include/linux/ethtool.h:254:2: error: expected specifier-qualifier-list before '__u32'
configure: In function 'main':
configure:19658:29: error: 'struct ethtool_cmd' has no member named 'speed_hi'
configure: failed program was:
#line 19655 "configure"
#include "confdefs.h"
#include <linux/ethtool.h>
int main() {
 struct ethtool_cmd cmd; cmd.speed_hi = 0;
; return 0; }
configure:19854: checking __attribute__ ((aligned ())) support
configure:19871: /tools/gcc-4.5/bin/gcc -c -gdwarf-2 -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -fno-tree-vrp -pthread -Werror  conftest.c 1>&5
configure:20579: checking for alsa
configure:20586: checking MOZ_ALSA_CFLAGS
configure:20591: checking MOZ_ALSA_LIBS
configure:20697: checking for libpulse
configure: error: pulseaudio audio backend requires libpulse development package
configure: error: /builds/slave/c-cen-t-lnx/build/mozilla/configure failed for mozilla
*** Fix above errors and then restart with               "make -f client.mk build"
make[1]: *** [configure] Error 1
make[1]: Leaving directory `/builds/slave/c-cen-t-lnx/build'
make: *** [objdir/Makefile] Error 2
program finished with exit code 2
elapsedTime=16.622840 

So apparently we need libpulse.  We need to disable libpulse until
we install pulseaudio/libpulse on our linux slaves.
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8347035 - Flags: review?(bugspam.Callek)
(In reply to Edmund Wong (:ewong) from comment #0)
[...]
> So apparently we need libpulse.  We need to disable libpulse until
> we install pulseaudio/libpulse on our linux slaves.

including, of course, the package(s) needed only to compile (libpulse-devel or whatever). I don't know which linux distro your slaves run but on openSUSE (which IIRC is similar to RedHat) I see
  libpulse-mainloop-glib0
  libpulse-mainloop-glib0-32bit
  libpulse0
  libpulse0-32bit
  libpulse-devel
which seem most relevant. (The -32bit packages are for running 32-bit applications on this 64-bit OS.)
I'm fairly sure that the version of libpulse (0.9.10) that you can get for CentOS 5.x is not a high enough for building in pulse audio support.
Comment on attachment 8347035 [details] [diff] [review]
proposed patch (v1)

Review of attachment 8347035 [details] [diff] [review]:
-----------------------------------------------------------------

Make sure other mozconfigs (e.g. l10n and release, etc.) specify this, to be safe incase it rides the trains so we don't have bustage on beta due to this error.

With that fixed r+
Attachment #8347035 - Flags: review?(bugspam.Callek) → review+
(In reply to Ian Neal from comment #4)
> I'm fairly sure that the version of libpulse (0.9.10) that you can get for
> CentOS 5.x is not a high enough for building in pulse audio support.

That's correct..  It requires at least 0.9.21.
Attachment #8347835 - Flags: review?(bugspam.Callek)
Comment on attachment 8347035 [details] [diff] [review]
proposed patch (v1)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None

Aurora needs this to build.
Attachment #8347035 - Flags: approval-comm-aurora?
Attachment #8347035 - Flags: approval-comm-aurora? → approval-comm-aurora+
OS: Windows Vista → Linux
Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/1ce77c2f9bd0
Pushed to comm-aurora.
https://hg.mozilla.org/releases/comm-aurora/rev/ad29705a9914
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.27
Patch still pending review.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Comment on attachment 8347835 [details] [diff] [review]
patch for l10n mozconfigs. (v1)

As per Callek's approval on irc, I'm closing bugs that have patches which have been pushed already.
Attachment #8347835 - Flags: review?(bugspam.Callek)
bug is pretty much irrelevant after bug 1047975
Status: ASSIGNED → RESOLVED
Closed: 6 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.