Closed Bug 949923 Opened 8 years ago Closed 8 years ago

Sync JIS X 0208 index with the Encoding Standard

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 593046

People

(Reporter: hsivonen, Unassigned, NeedInfo)

Details

http://coq.no/character-tables/japanese/en identifies seven JIS X 0208 characters whose Unicode mapping in Firefox differs from the mapping used by other browsers and the Encoding Standard.

We should align with other browsers and the Encoding Standard. When doing so, we should check for other differences (apart from the seven), too, just in case.
I don't know how coq inspected that, but Firefox matches other browsers and the Encoding Standard:
< escape(new TextDecoder('shift_jis').decode(new Uint8Array([0x81,0x5C,0x81,0x60,0x81,0x61,0x81,0x7C,0x81,0x91,0x81,0x92,0x81,0xCA])));
> "%u2015%uFF5E%u2225%uFF0D%uFFE0%uFFE1%uFFE2"
< escape(new TextDecoder('euc-jp').decode(new Uint8Array([0xA1,0xBD,0xA1,0xC1,0xA1,0xC2,0xA1,0xDD,0xA1,0xF1,0xA1,0xF2,0xA2,0xCC])));
> "%u2015%uFF5E%u2225%uFF0D%uFFE0%uFFE1%uFFE2"
< escape(new TextDecoder('iso-2022-jp').decode(new Uint8Array([0x1B,0x24,0x42,0x21,0x3D,0x21,0x41,0x21,0x42,0x21,0x5D,0x21,0x71,0x21,0x72,0x22,0x4C,0x1B,0x28,0x42])));
> "%u2015%uFF5E%u2225%uFF0D%uFFE0%uFFE1%uFFE2"
Also, U+FFE3 is typo of U+FFE2.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
coq, could you update the page if it is outdated?
Flags: needinfo?(pub-mozilla)
Henri, you fixed this yourself in bug 593046!
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 593046
Before filing the bug, I searched for the code points mentioned on coq.no in japanese.map, but I guess my interpretation of what I saw was incorrect.

Thanks.
You need to log in before you can comment on or make changes to this bug.