Metro "View Source" menu item should open a "child" tab

VERIFIED FIXED in Firefox 29

Status

Firefox for Metro
General
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: lpy)

Tracking

({polish})

28 Branch
Firefox 29
All
Windows 8.1
polish

Firefox Tracking Flags

(firefox28 wontfix, firefox29 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1) Open several tabs in Metro.
2) Select the leftmost tab, and navigate to any web page.
3) Press the menu button in the navbar and choose "View page source."

Expected results: The source opens in a new tab next to the originally selected tab.  After closing the "view source" tab, the original tab is selected again.

Actual results: The source opens in a new tab at the far right of the tab strip.  After closing the "view source" tab, the rightmost tab is now selected.

This should be an easy fix; just change the BrowserUI.addAndShowTab call added in bug 849564 to pass "Browser.selectedTab" as the second parameter, the "owner" tab.
(Assignee)

Comment 1

5 years ago
Created attachment 8347582 [details] [diff] [review]
bug950072.patch

add selectedTab as second argument.
Assignee: nobody → pylaurent1314
Attachment #8347582 - Flags: review?(mbrubeck)
(Reporter)

Comment 2

5 years ago
Comment on attachment 8347582 [details] [diff] [review]
bug950072.patch

Review of attachment 8347582 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8347582 - Flags: review?(mbrubeck) → review+
(Reporter)

Comment 3

5 years ago
Landed on fx-team:
https://hg.mozilla.org/integration/fx-team/rev/5b9b8b25aa79

Since this is not a release blocker, it does not need to be uplifted to Firefox 28.  It should be fine to land for Firefox 29 because it's a one-line patch that will not cause any non-trivial uplift conflicts.
Status: NEW → ASSIGNED
status-firefox28: --- → wontfix
status-firefox29: --- → fixed
https://hg.mozilla.org/mozilla-central/rev/5b9b8b25aa79
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29

Updated

5 years ago
No longer blocks: 861683, 849564
Whiteboard: [mentor=mbrubeck@mozilla.com][good first bug][lang=js]
Went through the following issue with the latest Nightly/Aurora builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-12-00-40-02-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-12-03-02-01-mozilla-central/

- Ensured that taping on "View page source" correctly opened a new "view-source" tab next to tab that spawned it
- Ensured that you can spawn multiple "view-source" tabs from the same website and they are correctly placed in the Tab App Bar
- Ensured that the "View page source" item is not available under "view-source" pages
- Ensured that you can close the "view-source" tabs without any issues
- Ensured that all of the above test cases worked under several different variations of snapped view
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.