Closed Bug 950143 Opened 6 years ago Closed 6 years ago

Remove the implicit conversion operator from nsIntSize to IntSize

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Details

(Whiteboard: [qa-])

Attachments

(4 files)

Attached patch Patch v1Splinter Review
This tends to cause double-copying; see e.g. bug 877115 comment 82 and the change in widget/gtk/nsWindow.cpp in this patch.
Attachment #8347375 - Flags: review?(roc)
Attached patch Part 2Splinter Review
Someone added a lot of callers, probably enough to warrant another review.
Attachment #8347738 - Flags: review?(roc)
Attached patch Part 3Splinter Review
*sigh*
Attachment #8351130 - Flags: review?(roc)
Comment on attachment 8351130 [details] [diff] [review]
Part 3

Review of attachment 8351130 [details] [diff] [review]:
-----------------------------------------------------------------

I think we need to move IntSize to the mozilla namespace. These gfx:: prefixes are ugly and pointless.
Attachment #8351130 - Flags: review?(roc) → review-
Comment on attachment 8351130 [details] [diff] [review]
Part 3

Review of attachment 8351130 [details] [diff] [review]:
-----------------------------------------------------------------

I don't think we should scope-creep this bug to include that.
Attachment #8351130 - Flags: review- → review?(roc)
I don't like scope-creep either. The problem is that here you're adding a lot of namespace prefixes which uglify the code.
I hope you appreciate this enough to make it worth the time.
Attachment #8354951 - Flags: review?(roc)
Comment on attachment 8354951 [details] [diff] [review]
Part 5: remove prefixes

Review of attachment 8354951 [details] [diff] [review]:
-----------------------------------------------------------------

I do appreciate it, but use "using namespace mozilla::gfx;" instead of "using gfx::...;".
Attachment #8354951 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/eea2c6adc544

Thanks.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
And had to land

https://hg.mozilla.org/mozilla-central/rev/c71b40e7fab8

because

using namespace android;
using namespace mozilla::gfx;

makes `Size` ambiguous.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.