[B2G][E.me][Collection] A new added collection are placed separately from other collections

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected)

Details

(Whiteboard: burirun1.3-1)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8347376 [details]
2013-12-13-13-54-33.png

Description:
The applications downloaded from Marketplace are placed on the e.me screen and the next added collections are placed separately from other collections

Prerequisites:
At least one screen is full with apps downloaded from Marketplace

Repro Steps:
1) Updated Buri to BuildID: 20131213004002
2) Long tap on the screen
3) Add any collection to the home screen

Actual:
The new added collection is placed separately from other collections

Expected:
All collections are placed together and applications downloaded from Marketplace don't place on the e.me screen

Device: Buri 1.3 Aurora Moz RIL
BuildID: 20131213004002
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Gecko: dfae9c83bfbc
Version: 28.0a2
Firmware Version: v1.2_20131115

Notes:
Repro frequency: 100%
See attached: screenshot
(Reporter)

Updated

5 years ago
status-b2g-v1.3: --- → affected
I don't think this is a bug. We should be able to add collections or apps to the homescreen in a location by user choice. We don't necessarily need to have collections on one page & apps on another.

Cristian - What do you think? Do you agree or disagree?
Flags: needinfo?(crdlc)
Flags: needinfo?(yosef)

Comment 2

5 years ago
Hi sarsenyev

This is not a bug. There isn't a dedicated area for collections. They just add in the first vacant slot in the grid.

I think this can be closed.
Flags: needinfo?(yosef) → needinfo?(sarsenyev)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(sarsenyev)
Flags: needinfo?(crdlc)
Resolution: --- → INVALID
(In reply to Jason Smith [:jsmith] from comment #1)
> I don't think this is a bug. We should be able to add collections or apps to
> the homescreen in a location by user choice. We don't necessarily need to
> have collections on one page & apps on another.
> 
> Cristian - What do you think? Do you agree or disagree?

Hi Jason,

   Applications are placed in the first free slot but the collections are added pressing and hold in some page. So an user for example goes to third page and presses and holds there in order to add a new collection. For us to add this new one on the third page makes sense in order to get feedback. In the use case for applications, they are added in the first free slot because you're not in the homescreen at that moment (marketplace, bookmarking from browser, etc..) and you receive feedback via reading a status message from bottom showing 'Bookmark added' or application installed, etc.

   I think that the correct behavior is already implemented but it is just my opinion. I followed the UX instructions when I did it with evme guys

Thanks
You need to log in before you can comment on or make changes to this bug.