Add search suggestions to Bing search plugin

VERIFIED FIXED in Firefox 29

Status

()

VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: mconnor, Assigned: mconnor)

Tracking

({feature})

27 Branch
Firefox 29
ARM
Android
feature
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(relnote-firefox 29+)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Split off from bug 903084.

Waiting on formal clarification from Bing about the correct URL to use, as well as a new API code (different from the form code) to be used for mobile.  Once we have that, I'll fix it here.
(Assignee)

Comment 1

5 years ago
Created attachment 8349738 [details] [diff] [review]
bingMobileSuggestions

This _should_ be correct, but should be verified (I don't have a Fennec build env)
Attachment #8349738 - Flags: review?(margaret.leibovic)
Comment on attachment 8349738 [details] [diff] [review]
bingMobileSuggestions

Review of attachment 8349738 [details] [diff] [review]:
-----------------------------------------------------------------

I verified this makes bing suggestions appear in the UI. r+ assuming this is the correct url/parameters.
Attachment #8349738 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/23eade41cfcc

Happy to take on uplifts if product people think it's worth it
Mike - the thread with Bing is using language I'm not very familiar with. Is Margaret's patch in line with their expectations and are you confident it's within agreement between us and Bing (in terms of expectation, use of our currently-used FORM code, etc etc)?

Thanks!
https://hg.mozilla.org/mozilla-central/rev/23eade41cfcc
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
testing-note (12/20): Only the default provider is currently used in fennec; not sure which is the penultimate bug to handle multiple providers
Correct - and to be clear, search suggestions should only appear for the default provider if suggestions are available. So if the user has made Bing their default provider, Bing's search suggestions should appear (and not Google's, since they would not be in the default position).
Flags: in-moztrap?(fennec)
Might be worth a relnote.
relnote-firefox: --- → ?
Keywords: feature
(Assignee)

Comment 9

5 years ago
Karen, it's actually my patch, based on Bing's confirmation that it's the correct bits to use.  We may need to change the API code, but this is functionally correct.  I'll continue to follow up and make changes where needed, but this will address the immediately urgent issue.
(In reply to Mike Connor [:mconnor] from comment #9)
> Karen, it's actually my patch, based on Bing's confirmation that it's the
> correct bits to use.  We may need to change the API code, but this is
> functionally correct.  I'll continue to follow up and make changes where
> needed, but this will address the immediately urgent issue.

I think Karen was responding to Aaron. To paraphrase, comment 6 is describing it working as intended.

Comment 11

5 years ago
Nightly 29.0a1 (2013-12-26)
Galaxy Tab (Android 4.0.3 )

"Would you like to turn on Bing search suggestions " is present. Choosing yes will display the suggestions. 
Settings this to VERIFIED FIXED.
Status: RESOLVED → VERIFIED

Comment 12

5 years ago
Test cases covering this:
https://moztrap.mozilla.org/manage/case/2739/
https://moztrap.mozilla.org/manage/case/2740/
I've modify them to include bing too starting Mobile Firefox 29 (both phone and tablet).
Flags: in-moztrap?(fennec) → in-moztrap+
relnote-firefox: ? → 29+
It would be good to modify the relnote so that it states:  "Search suggestions are now available with the Bing search plugin when it is set as the default search engine"
Flags: needinfo?(lsblakk)
Ok, try this: "Bing search suggestions available when set to default"

Comment 15

5 years ago
We settled on using this line and it has posted to the release notes: 
Search suggestions available via Bing search plugin when set as default search engine
Flags: needinfo?(lsblakk)
You need to log in before you can comment on or make changes to this bug.