Closed Bug 950224 Opened 6 years ago Closed 6 years ago

Title bar of out of focus private windows is drawn incorrectly (OS X)

Categories

(Core :: Widget: Cocoa, defect, minor)

27 Branch
x86_64
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 941559

People

(Reporter: cosimocampo, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0
Build Id:   Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0

On OS X, when a Private Browsing window goes out of focus, the title bar remains grey instead of becoming white, like the rest of the window does. This did not happen in the previous version of Firefox (26).

Reproducible: Always

Steps to Reproduce:
1. Open a new Private Window
2. Switch to the Finder using Cmd+Tab, or switch to a window of any other application with the main Firefox window visible in the background

Actual Results:
The title bar remains grey as when it was in focus, while the rest of the interface becomes white

Expected Results:
The title bar should become white like the rest of the interface
Component: Theme → Widget: Cocoa
Keywords: regression
Product: Firefox → Core
This was fixed for Firefox 28 in bug 941559.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 941559
You need to log in before you can comment on or make changes to this bug.