[B2G][Settings][Passcode]User is not taken directly to passcode screen after restarting.

NEW
Unassigned

Status

Firefox OS
Gaia::Settings
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1.3-1)

If passcode is enabled and the user restarts their device, they should be taken to the passcode unlock screen when the device reboots. Instead, the user is taken to the swipe to unlock screen. After swiping, the user must then input a passcode before being permitted to use the device.

Repro Steps:
1) Updated Buri to Build ID: 20131213004002
2) Enable passcode in settings. (Settings >> Screen Lock >> Passcode Lock)
3) Restart device.

Actual:
After restarting, user is taken to 'swipe to unlock' page.

Expected:
After restarting, user is taken to 'enter passcode' page.

Environmental Variables
Device: Buri v1.3 COM RIL
Build ID: 20131213004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/dfae9c83bfbc
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: 20131115

Notes:
Repro frequency: 100%
Issue also occurs in 1.2

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131212004004
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8bae10bb0aed
Gaia: 6d02039072a2ae5cf9225a6f4c78ed49decfab5c
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_20131115
Does this reproduce on 1.1?
Keywords: qawanted

Comment 3

4 years ago
This bug also occurs on 1.1. After restarting the device while passcode is enabled, user is first asked to swipe to unlock then afterwards the passcode input screen appears.

Device: Buri 1.1 MOZ
BuildID: 20131213041208
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: bdac595a4e46
Version: 18.0
Firmware Version: V1.2_20131115
Keywords: qawanted
QA Contact: nkhristoforov
You need to log in before you can comment on or make changes to this bug.