SetLocalDescription fails to fire success or error if there's no IP address on B2G

RESOLVED DUPLICATE of bug 827982

Status

()

RESOLVED DUPLICATE of bug 827982
5 years ago
3 years ago

People

(Reporter: jesup, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #950317 +++
From jsmith's bug 950317 comment 4:

> Note - there still is a bug here in the P2P code. We should eventually fire a callback
> for any handshake-based function, even if the function call will cause an error. We 
> shouldn't timeout by having no success or error callback fire.

It's unclear without investigation if this only applies to B2G, or if a similar failure could occur on desktop.  We do have a number of intermittent desktop failure-to-exit oranges at lowish frequency, so perhaps it's related.  Also I'd like to know if the same problem would happen on real B2G devices if the 3G/4G network is disabled by the user or not reachable.

Comment 1

5 years ago
This is effectively the same issue as bug 827982.
technically not a blocker for pref on, so removing blocking & dependencies
Blocks: 750011
No longer blocks: 945256
No longer depends on: 950317
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827982
You need to log in before you can comment on or make changes to this bug.