Closed Bug 950364 Opened 6 years ago Closed 6 years ago

Adblock plus icon disappears from Nightly 29.0a1 toolbar

Categories

(Firefox :: Theme, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: witdafje, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131214030204

Steps to reproduce:

After installing Nightly 19.0a1 I added the Hola Unblocker 1.2.165 and Adblock Plus 2.4.



Actual results:

After the install process, the icon, which normally should be placed on the add-on bar (in Firefox) does not appear anywhere. (the add-on bar does not appear at all)
I then clicked on Customize in the "Customize and Control Nightly" menu and on "Restore Defaults" on the lower left.
Then the Adblock Plus icon appears on the page and can be dragged to the right of the search-bar.
After closing and reopening Nightly the icon has dissapeared.
Although the icon for the Hola Unblocker is placed right from the search-bar, after restoring the Adblock icon, this icon has also disappeared, although it wil stay when you drag it there again.


Expected results:

The Addon toolbar should appear with the icon, or the icon should stay left from the searchbar after moving it there. The Hola icon should not be effected by the customizing action to place the Adblock icon.
Component: Preferences → NSPR
Product: SeaMonkey → NSPR
Hardware: x86 → x86_64
Version: unspecified → other
Component: NSPR → Theme
Product: NSPR → Firefox
Version: other → Trunk
Confirming. We've had a bunch of bugs related to icons & Australis changes (e.g. bug 940953), maybe this is related?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can you reproduce this now? There may have been some changes between when you filed this bug and now that have fixed this.
Flags: needinfo?(witdafje)
I confirmed the bug (Adblock Plus icon disappears on restart) on currentl Nightly yesterday (2014-01-03 Nightly).
Flags: needinfo?(witdafje)
You don't need the Hola Unblocker btw, just Adblock Plus already reproduces it. Add the icon to the toolbar (via the add-ons->options->show in add-on bar). Restart Nightly, and it's gone.
(In reply to Jared Wein [:jaws] from comment #2)
> Can you reproduce this now? There may have been some changes between when
> you filed this bug and now that have fixed this.

Sorry I didn't reply sooner, but I was away.
The problem still exsists in de latest release of version 29.0a1 (2014-01-10).
And an other problem is introduced: after exiting Nightly an instance of firefox stays active. Only after ending the process, Nightly wil start. Not for a moment, but until the process is stopped.
Don't know if this has to do with the original problem.
(In reply to Gian-Carlo Pascutto (:gcp) from comment #4)
> You don't need the Hola Unblocker btw, just Adblock Plus already reproduces
> it. Add the icon to the toolbar (via the add-ons->options->show in add-on
> bar). Restart Nightly, and it's gone.

The Hola Unblocker isn't an add or 'what have you' blocker, it unblocks websites from country's that are only accessible from that country.
I wasn't commenting on the usefulness of the add-on, I'm pointing out it's not relevant to this bugreport because Adblock Plus by itself already shows the problem.

>And an other problem is introduced: after exiting Nightly an instance of firefox stays active. Only after ending the process, Nightly wil start.

This is a separate problem/bug. (And somewhat more likely a bad plugin/addon, than a Firefox bug)
Of course Restoring Defaults wil also remove the Hola icon from the toolbar. This is normal behaviour and not part of the bug. Sorry.
(In reply to Gian-Carlo Pascutto (:gcp) from comment #7)
> I wasn't commenting on the usefulness of the add-on, I'm pointing out it's
> not relevant to this bugreport because Adblock Plus by itself already shows
> the problem.
> 
> >And an other problem is introduced: after exiting Nightly an instance of firefox stays active. Only after ending the process, Nightly wil start.
> 
> This is a separate problem/bug. (And somewhat more likely a bad
> plugin/addon, than a Firefox bug)

Your right, after removing all plugins Nightly exited without probem.
Can it be that the problem is caused bij the option "Show in add-on bar" which is not selectable in Nightly?
Blocks: abp
This issue is due to missing Australis support in Adblock Plus 2.4. Australis support has been present in Adblock Plus development builds for a while and it is also in Adblock Plus 2.4.1 which has been released today (not reviewed by AMO yet).
(In reply to Wladimir Palant from comment #11)
> This issue is due to missing Australis support in Adblock Plus 2.4.
> Australis support has been present in Adblock Plus development builds for a
> while and it is also in Adblock Plus 2.4.1 which has been released today
> (not reviewed by AMO yet).

I thought that, but I noticed this bug in the middle of a work week triage and didn't have time to investigate further. I'm going to just mark this WFM based on the above. Thank you for the quick response!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
After installing Adblock plus 2.4.1, the icon is placed between the menu and the home icon.
After a restart the icon stays visible.
The issue is solved.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.