Closed Bug 950397 Opened 8 years ago Closed 6 years ago

Firefox 26 crashes randomly under VMware without showing the bug reporting dialogue.

Categories

(Core :: General, defect)

26 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: ultrasonicmadness, Unassigned)

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131210132641

Steps to reproduce:

This happens on many web pages, mostly YouTube profiles, but the most reliable way I have found to reproduce this is by typing http://en.wikipedia.org/wiki/Last.fm into the address bar and pressing enter.


Actual results:

Firefox tried to load the page but closed without showing the bug reporting dialogue that is usually shown when it randomly closes.


Expected results:

Firefox should have loaded the Wikipedia article for Last.fm.
I should probably add that I'm using Fedora 19 MATE Edition and I have Adobe Flash Player 11.2.202.332 and OverbiteFF 3.0.1627 installed as addons.

In addition to the above, when Firefox is opened after the crash explained above, it opens with about:sessionrestore listing all of the pages I had open before the crash happened. It wouldn't list the page which crashed the browser, in the above case, the Wikipedia article on Last.fm.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
I apologise for wasting your time, apparently reinstalling Firefox twice fixes the problem...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I apologise for the previous apology: the problem is still there, just not as bad as it was before.
Now Midori does the same thing when visiting thatguywiththeglasses.com. I would be convinced that this is a problem with Adobe Flash if Wikipedia wasn't affected.
Works for me on Ubuntu 13.10 32-bit, with latest Nightly (build ID: 20131215030202)


Could you please update your GPU driver, and then try the following :

1) try this with a clean profile: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
It just happens that an update for the NVIDIA X server came to RPMFusion today. I cleared the profile and now it's like the old firefox again!

Many thanks and best regards,
UltrasonicMadness
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
UPDATE: The problem still seems to be affecting me, despite new drivers and clearing out the profile. Thatguywiththeglasses.com still seems to be badly affected by this.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Flags: needinfo?
Can you also reproduce this, if you're running in safe mode?
Flags: needinfo?
Strangely not. Here's a list of things I did which didn't fix the problem:

1. Clear the profile, as you suggested
2. Install an update for the NVIDIA X Server from RPMFusion, also as you suggested
3. yum reinstall firefox
4. yum erase firefox, followed by yum install firefox
5. Remove OverbiteFF (gopher addon)
6. I may have even tried removing Adobe Flash

I should also add that I never touched about:config, I only looked at it a couple of times, if that. The only configuration changes I remember making were the homepage (set to last viewed) and turning off smooth scrolling.
Flags: needinfo?
Flags: needinfo?
ADDITIONAL INFORMATION:

An update from my package manager installed the Automatic Bug Reporting Tool, which now appears when Firefox shuts down. It claims that Firefox was killed by 'SIGSEGV'.
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
[bumping from CSS to General component; it doesn't look to me like we've determined what area of code is involved yet]
Component: CSS Parsing and Computation → General
Keywords: crash
Summary: Firefox 26 closes randomly without showing the bug reporting dialogue. → Firefox 26 crashes randomly without showing the bug reporting dialogue.
Upgraded to Fedora 20 MATE Edition, it's still a problem and it's stopped showing the bug report dialogue again. I assume it's the same problem as it has the same symptoms and happens on the same websites as before.
I have observed the same thing happening in VMware (just under a second after the VM is started), although curiously not with VirtualBox. I'm considering moving this to LinuxQuestions.
I have managed to reproduce this issue in a very consistent way. Firefox is set up to start using the "windows and tabs from last time". The session consists of 3 separate instances of Munin, all password protected (htaccess) and 1 instance of Twitter. Here are the various situations I tried and the result:

- Normal start, all plugins and extensions disabled: CRASH, whether logged into Twitter or not
- Normal start, all addons/plugins disabled; press ESC when Firefox offers the login/password dialog for 2 or 3 of the Munin pages: NO CRASH. Reload the unauthenticated Munin pages: STILL NO CRASH
- Start in safe mode: NO CRASH

It makes no difference whether FF starts normally or if the session is restored through the "Restore" dialog.

The crash occurs in the first few seconds after FF starts. When it happens, memory usage goes up quite a bit (about 1GB) and if started from a terminal, a standard segmentation fault message appears. The crash dialog does not show. Clearing FF's cache does not help, nor does the "Reset Firefox" feature.
I am seeing this on two different systems, both 64-bit Intel. I had no such problems with Firefox 25 with the very same pages.

It sure looks like simultaneity is a factor here. I cannot share the Munin URLS for obvious privacy reasons, but I'd be glad to help in any other way. However, I don't believe the content of the pages is important, but that's just a gut feeling. I'll have to try investigating a little further with the Profile manager now.
(In reply to Romain Riviere from comment #14)

I just tried with a clean profile and the results are exactly the same as above.

I forgot to mention 2 potentially important things:
- The "Dont load tabs until selected" is not ticked. If ticked, the problem goes away. So simultaneity is definitely a factor.
- I use FF Sync, so the login/pass dialogs are already filled-in, which means I can validate them pretty quickly. Still, not pressing Enter is not enough to prevent the crash.
Further investigation shows that, in my case, this problem was caused by the latest NVidia drivers, which were updated at about the same time. See: https://bugs.archlinux.org/task/38085
Severity: normal → critical
Reporter, do you still see this problem? (note - NI is disabled)
Summary: Firefox 26 crashes randomly without showing the bug reporting dialogue. → Firefox 26 crashes randomly under VMware without showing the bug reporting dialogue.
Whiteboard: [closeme 2015-10-20]
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-10-20]
You need to log in before you can comment on or make changes to this bug.