ACE Stream plugin won't start in Firefox 28

VERIFIED WORKSFORME

Status

()

P4
normal
VERIFIED WORKSFORME
5 years ago
3 years ago

People

(Reporter: mackeev, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28+ verified, firefox29+ verified)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131214004001

Steps to reproduce:

Tried to start an ace stream on http://torrent-tv.ru


Actual results:

Got a message "ACE Stream P2P Multimedia Plugin is not installed" and suggestion to install it.


Expected results:

Plugin IS installed and worked just fine on all previous versions of Aurora.
Streaming should have started!

Comment 1

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0

Reproduced with Aurora 28.0a2 (Build ID: 20131217004003): after I install Ace Stream P2P Multimedia Plug-in 2.1.9.0, the message "ACE Stream P2P Multimedia Plugin is not installed on your computer" is displayed and streaming doesn't start. Works with Chrome and Opera.
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Product: Firefox → Core

Comment 2

5 years ago
Caused somewhat intentionally by bug 757726:

This is the code at http://torrent-tv.ru/js/core.js:

            for (var i=0; i < navigator.plugins.length; i++) {
                    if(navigator.plugins[i].name.match(/Torrent Stream P2P Multimedia Plug-in 2/gim)) {
                        if(p === false) {
                            p = 3;
                        }
                    }
                    else if(navigator.plugins[i].name.match(/Torrent Stream P2P Multimedia Plug-in/gim)) {
                        if(p === false) {
                            p = 1;
                        }
                    }
                    else if(navigator.plugins[i].name.match(/ACE Stream P2P Multimedia Plug-in/gim)) {
                        p = 2;
                    }
                    else if(navigator.plugins[i].name.match(/ACE Stream Multimedia Plug-in/gim)) {
                        p = 4;
                    }
            }

The best solution would be for this site to stop enumerating navigator.plugins and instead check navigator.mimeTypes['mimeType'].
Blocks: 757726
Assignee: nobody → other
Component: Plug-ins → Other
Product: Core → Tech Evangelism
Version: 28 Branch → Trunk

Comment 3

5 years ago
Kohei, please don't move these bugs to TE until/unless we are sure that we aren't going to add the plugin to the in-product blocklist. TE is where bugs go to die and not be tracked.
Assignee: other → nobody
tracking-firefox27: --- → ?
Component: Other → Plug-ins
Product: Tech Evangelism → Core
Switching the tracking flag from Firefox27->28 per bug description.
status-firefox27: --- → unaffected
tracking-firefox27: ? → ---
tracking-firefox28: --- → ?
I tried pinging torrent-tv.ru on Twitter and their website's Contact form.

Do we have a better way to contact them?
That's a good start, let us know if you hear back from them, tracking to make sure we stay on top of this.
status-firefox28: --- → affected
status-firefox29: --- → affected
tracking-firefox28: ? → +
tracking-firefox29: --- → +
(Reporter)

Comment 8

5 years ago
I reported this problem to them the same day I posted it here. BTW, this affects all sites that provide ace streaming content.
The only reply I got so far was "We'll think about it when FF 28 is released."
Maybe you'll have more luck.
If we want to whitelist the ACE Stream video plugin, we will need to add the "ACE Stream" plugin name prefix to the `plugins.enumerable_names` pref. I do not think we should include the "Torrent Stream P2P Multimedia Plug-in" name because that is an older version of the same plugin.

That said, whitelisting plugins to fix a torrent website is not a high priority on my to-do list. :)
Priority: -- → P4
Summary: Ace Stream plugin won't start in Aurora 28 → ACE Stream plugin won't start in Firefox 28
(Reporter)

Comment 10

5 years ago
The problem has been fixed.
WFM too with latest Aurora and Nightly builds from 2014-01-28.
It's also fixed on Aurora from 2013-12-14 (comment 0).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

5 years ago
There are some sites out there that are still affected (e.g., http://raketa-tv.com), but it's their loss (they are, so to speak, trailing behind in technology).
Awesome! Thanks for testing this, Igor and Alexandra. :)
status-firefox28: affected → fixed
status-firefox29: affected → fixed
Marking verified based on above testing.
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified
status-firefox29: fixed → verified
You need to log in before you can comment on or make changes to this bug.