--with-libxul-sdk builds broken by bug 935881

RESOLVED FIXED in Firefox 28

Status

()

Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla29
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28 fixed, firefox29 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Essentially, the build system complains that the FINAL_LIBRARY for mfbt, which is mozglue, is unknown. That's because, really, we shouldn't be building mfbt at all when building --with-libxul-sdk, as it's part of the sdk.
(Assignee)

Comment 1

4 years ago
Created attachment 8347839 [details] [diff] [review]
Don't build mfbt when building --with-libxul-sdk
Attachment #8347839 - Flags: review?(gps)
(Assignee)

Updated

4 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED

Updated

4 years ago
Attachment #8347839 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/b545ee26212b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
(Assignee)

Comment 4

4 years ago
Comment on attachment 8347839 [details] [diff] [review]
Don't build mfbt when building --with-libxul-sdk

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 950531
User impact if declined: Building firefox-on-xulrunner, or any libxul-sdk-based application using our build system fails.
Testing completed (on m-c, etc.): Patch is used on debian to build iceweasel-on-xulrunner.
Risk to taking this patch (and alternatives if risky): Effectively a noop for tbpl builds.
String or IDL/UUID changes made by this patch: None
Attachment #8347839 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
status-firefox27: --- → unaffected
status-firefox28: --- → affected
Attachment #8347839 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/4efc91df009d
status-firefox28: affected → fixed
status-firefox29: --- → fixed
You need to log in before you can comment on or make changes to this bug.