Mail Server and User Name for Mail Account cannot be changed

VERIFIED DUPLICATE of bug 14295

Status

VERIFIED DUPLICATE of bug 14295
17 years ago
14 years ago

People

(Reporter: marian, Assigned: racham)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
As the image behind the given URL shows, on the Server Settings pane of a mail
account, the server address and the user name for the account cannot be changed.

I experienced this to be a usability issue. When I added a new POP Account to
MailNews, I missspelled both server name and user name. In order to correct
this, I had to delete the account and recreate it from scratch. Is this wanted?

I imagine it to be worse if had saved a bunch of messages under that account and
would then need to change either the server name or the user name, due to
changes on my providers side. Would the mail then be lost?

I suggest to the developers to key the account settings somehow different, so
that user name and server can be changed whenever needed. I saw that local mail
is stored in a folder named after the server name. I would consider this a
design issue. Picking an artificial, unambigious and unique key for the folder
would eliminate the need to keep the server name for the account fixed (if
that's the reason).

Thanks a lot!

Marian
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Duplicate of "UI: Account Settings, Server Panel, username & Server Name not
editable"

*** This bug has been marked as a duplicate of 14295 ***

Comment 2

17 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.