MHT support for offline storage of pages

RESOLVED DUPLICATE of bug 40873

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 40873
17 years ago
14 years ago

People

(Reporter: tomer, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

Once I've moved from Netscape to the alternatives, I've found that IE's
File-Save option is can't be compared to the same option in any exist browser -
it has the option to download the file and save is as html only, html and
pictures (in a special folder, if I do not wrong, it is something like
.\filename-images\), and - mht.

MHT stands for a file, which include the html file itself and the whole
multimedia elements used - in the same file. For people like me, whom doesn't
have yet a 24h connection, this is sometimes more usfull then just bookmarking,
because it's made for offline reading. It would be great if Mozilla will be able
to read and produce those files.

Another ideal support for Microsoft standards is CHM support. CHM stands for
something like multiple MHT files in one file. Microsoft use this in the help
system of win98 and on, but it's more usfull for offline surfing, for example -
to save a large tutorial into one piece, and then, to read it, in a free time.
Write support for CHM is not necessary, it's a job for external program, I
guess. (The same goes in Microsoft arena - MHT you can write easily, but for CHM
you need to download from microsoft a program named "CHM factory", or something
with a semiliar name)
Duplicate of "RFE: Save as rfc 2557 MHTML; complete webpage in one file"

*** This bug has been marked as a duplicate of 40873 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Bug 40873 does not cover CHM support. But I don't know if MS has documented the
CHM format (I found no documentation at their site). gzip'ed MHTML can do the
same (but may be slower because it lacks an index of its contents). My fix for
bug 18764 will include the ability to browse a whole website (or more) stored in
a single MHTML file. Mozilla cannot open gzip'ed local files, though (don't know
if we have a bug for that).

Reporter, if you still want an RFE for CHM support, please file a new bug or
reopen this one and morph it accordingly.

Comment 3

17 years ago
fwiw I think we have an rfe somewhere about supporting CHM, and i would think 
that the zip file format would make a lot of sense (we already use the decoder) 
it includes an index and we do try to make zip handling fast.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.