Closed Bug 950933 Opened 6 years ago Closed 5 years ago

Support one-click install CDM plugins

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1089867

People

(Reporter: Unfocused, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: not yet estimatable)

Attachments

(1 file)

We want to add two new types of add-on that supply a CDM plugin or a media decoder plugin to Gecko. These would be similar to dictionary add-ons, in that they would include only metadata (install.rdf) and the actual library - glue to register the library with Gecko will be handled by a bootstrap file provided by XPIProvider (just like SpellCheckDictionaryBootstrap.js).

Additionally, a standard list of these plugins should be available in about:addons for one-click download and install. This fits in nicely with the concept of "advertised available installs" I've been thinking about.
"one-click" isn't quite right here. These add-ons should both be auto-downloaded
by Firefox upon install.
I'm currently breaking down the work for openh264. Since that is public, let's please decide on openh264 in bug 1009816 and leave this a private bug about CDM plugins. The UI and requirements for a CDM are different anyway.
Summary: Support one-click install CDM and decoder plugins → Support one-click install CDM plugins
Group: mozilla-employee-confidential
Blocks: OpenH264
Assignee: bmcbride → nobody
No longer blocks: OpenH264, fxdesktopbacklog, 1009816
Flags: firefox-backlog+
Whiteboard: not yet estimatable
Blocks: 1009909
No longer blocks: 1009909
Attached patch WiP v1 (ancient)Splinter Review
This is an ancient WiP for my original plan. Never attached to a bug, because EME was a bit too hush-hush at the time. It follows the plan described in bug 1009909 comment 20 and bug 1009816 comment 21. It would be dependant on bug 985380.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089867
You need to log in before you can comment on or make changes to this bug.