[Tablet] Usb charging detection cannot work well on device with higher power consumption

RESOLVED DUPLICATE of bug 928884

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 928884
5 years ago
4 years ago

People

(Reporter: dliang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The usb charging detection cannot work well on device with higher power consumption, it will cause the screen is on/off frequently when idle with usb charging.

In this case, device cannot be charging by USB when screen on, due the screen on power consumption exceed 500mA. When device idle by screen timeout, the power consumption became lower than 500mA when screen off, so that device is under charging with USB. Then screen is on by battery state update. Repeat above cycle, we can see the screen is on/off frequently on higher power consumption device.

How to reproduce:
1. Plug USB cable on higher power consumption device.
2. Let device idle 

Actual results:
The screen is on/off frequently with USB charging.

Expected results:
No frequently screen switch with USB charging.
(Reporter)

Updated

5 years ago
Depends on: 911121

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928884
You need to log in before you can comment on or make changes to this bug.