After 10.9.1 upgrade, Firefox sometimes hangs when trying to use plugins and gfxCardStatus

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P2
critical
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Joe Drew (not getting mail), Assigned: smichaud)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox26- affected, firefox27 affected, firefox28 affected, firefox29 affected)

Details

(Reporter)

Description

5 years ago
I just updated to 10.9.1, and the presence of a plugin on a page is enough to hang my Firefox. I'm 95% sure that it's happening because of some problem/change in GL.

gdb shows me:

Thread 1 (process 1045):
#0  0x00007fff9140fa1a in mach_msg_trap ()
#1  0x00007fff9140ed18 in mach_msg ()
#2  0x00007fff915385ee in io_service_open_extended ()
#3  0x00007fff914e094e in IOServiceOpen ()
#4  0x00007fff8b50bf50 in CGLRestoreDispatchFunction ()
#5  0x00007fff8b50f6d8 in CGLChoosePixelFormat ()
#6  0x00007fff8b50ee0a in CGLChoosePixelFormat ()
#7  0x00000001015f1ae9 in imgLoader::SupportImageWithMimeType ()

I had more details in the Apple crash reporter before, but I can't find them any more.
(Reporter)

Comment 1

5 years ago
BTW: Firefox 26.0, Flash Version: 11.9.900.170, though it also happens with the Google Talk plugin (Version: 4.8.2.15856).
I assume you can't get better stacks here?
Is this with both visible and invisible plugins?

Steven, any good ideas for next steps?
Flags: needinfo?(smichaud)
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 3

5 years ago
I had a way better stack from the Apple hang reporter ("You forced this app to quit, do you want to submit info to Apple"), but it no longer pops up, probably because I told it to automatically submit. Is there an easy way of undoing that decision?

As far as I can tell it's only with visible plugins, but I haven't tested extensively.
You might be able to get the hang/crash report from the Console under Applications > Utilities. I believe they should appear under "User Diagnostic Reports".
(Reporter)

Comment 5

5 years ago
Nothing Firefox in there, sadly. :/
(Assignee)

Comment 6

5 years ago
This kind of thing is right up my alley :-)

I'll start by trying to reproduce it.  If I can't, I may need some help from the rest of you.
Assignee: nobody → smichaud
Flags: needinfo?(smichaud)
(Assignee)

Comment 7

5 years ago
OK, I can't reproduce this, so I need more information:

Please give examples of pages on which these hangs occur.

Do they happen with a clean profile?
(Assignee)

Comment 8

5 years ago
Joe, it may also help to know what hardware you're running on.  (I'm using a Retina MacBook Pro, which I just upgraded from 10.9 to 10.9.1.)
(Assignee)

Comment 9

5 years ago
Can anyone else (besides Joe) reproduce these hangs?
By the way, we shouldn't track these if they aren't reproducible.
(Assignee)

Updated

5 years ago
Flags: needinfo?(joe)
(Reporter)

Comment 11

5 years ago
I'm on a Retina MBP (Retina, 15-inch, Early 2013) too.
Flags: needinfo?(joe)
(Reporter)

Comment 12

5 years ago
Steven - are you using your discrete GPU (i.e., because you've connected to an external monitor)? (I'm not.)
(Reporter)

Comment 13

5 years ago
Oh, and it happens on literally every page that invokes a plugin; YouTube is a good example.
(Reporter)

Comment 14

5 years ago
Hm, but I can't reproduce in a clean profile... and now that I try again, I can't reproduce it at all. What the eff.

Possibly related to gfxCardStatus?
> Steven - are you using your discrete GPU (i.e., because you've connected to an external monitor)?

No, I'm not.  Though I could.  I have gfxCardStatus (which I'm not using at the moment).  I also have an external (non-Retina) monitor (which isn't connected at the moment).

> Possibly related to gfxCardStatus?

Let us know if you find out.

In the meantime, let's mark this WORKSFORME :-)
(Reporter)

Comment 16

5 years ago
OK. Will keep you apprised.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
I saw this same kind of hang today with WebGL. I'm also using gfxCardStatus.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: After 10.9.1 upgrade, Firefox always hangs when trying to use plugins → After 10.9.1 upgrade, Firefox always hangs when trying to use plugins and gfxCardStatus
Jeff, we need STR.  Without that we can't do anything.
(Assignee)

Updated

5 years ago
Flags: needinfo?(jmuizelaar)
I don't see any hangs playing around with gfxCardStatus (with and without an external monitor) on either www.vg.no (a horribly noisy site with lots of Flash stuff) or with random YouTube videos on their main page.
My version of gfxCardStatus is 2.3 -- the current version.
(Assignee)

Updated

5 years ago
Summary: After 10.9.1 upgrade, Firefox always hangs when trying to use plugins and gfxCardStatus → After 10.9.1 upgrade, Firefox sometimes hangs when trying to use plugins and gfxCardStatus

Comment 22

5 years ago
Is plugin-container eating CPU or not?
Joe:  Do these hangs stop happening if you disable the Google Talk plugin?

Jeff:  Do you have the Google Talk plugin installed?
The current version of the "Google Voice and Video" installer (which among other things installs the googletalkbrowserplugin.plugin) also installs another plugin (npgtpo3dautoplugin.plugin) that includes a crash reporter.  So the second plugin (at least) must handle crash signals (like SIGSEGV).

So possibly this bug is similar to bug 932678, where a component (Mono) of the Unity plugin mishandled a SIGSEGV, causing the plugin to hang.

Note that bug 932678 was caused by an incompatibility between part of Mono and OS X 10.9.
> Joe:  Do these hangs stop happening if you disable the Google Talk plugin?

In light of comment #24, you'd need to disable both googletalkbrowserplugin.plugin and npgtpo3dautoplugin.plugin.  Or better yet remove them both from /Library/Internet Plug-Ins/.
(Assignee)

Updated

5 years ago
Flags: needinfo?(joe)
(Assignee)

Updated

5 years ago
Blocks: 883824
This isn't being hit (that we know of) by a lot of users so please continue investigation and attempts to reproduce but there's nothing to track here yet.  Renom if there's a clear STR and we have data that shows  this has a high impact.
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → affected
status-firefox29: --- → affected
tracking-firefox26: ? → -
Priority: P1 → P2
(Reporter)

Comment 27

5 years ago
I actually haven't been able to reproduce these hangs since comment 14 :(
Flags: needinfo?(joe)
(In reply to Steven Michaud from comment #23)
> Joe:  Do these hangs stop happening if you disable the Google Talk plugin?
> 
> Jeff:  Do you have the Google Talk plugin installed?

Yes. Though the stacks I saw from when this happened were from webgl initialization.
Flags: needinfo?(jmuizelaar)
If nobody sees these hangs anymore, they're WORKSFORME.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.