Closed Bug 951141 Opened 8 years ago Closed 8 years ago

[ro] "Open Sans" font rendered incorrectly

Categories

(Core :: Layout: Text and Fonts, defect)

26 Branch
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 907793

People

(Reporter: cristian.adam, Unassigned)

Details

Attachments

(5 files)

Attached image opensans_ff26.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131115105349

Steps to reproduce:

Rendered this html code on a Windows 8 machine:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> 
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/> 
<link href='http://fonts.googleapis.com/css?family=Open+Sans:400,700,300,400italic&subset=latin,latin-ext' rel='stylesheet' type='text/css'>
<style type="text/css">
h1 {
	font-family: "Open Sans";
	font-size: 36px;
	font-weight: normal;	
	margin: 10px 0 20px 0;
}
</style>
</head>

<h1 lang="ro">&#354;&#355; &#350;&#351; (cedilla)</h1>
<h1 lang="ro">&#538;&#539; &#536;&#537; (comma) </h1>

</html>



Actual results:

Rendered text had only cedilla characters.


Expected results:

Mozilla Firefox should have rendered like IE10 or Chrome31.
Attached image opensans_chrome31.png
Attached image opensans_ie10.png
Note that this doesn't happen on a Linux build of Firefox.
Real life website affected by this: http://scriuromânește.net/
OS: Linux → Windows 8
I confirm the issue with Firefox 26 on Arch Linux x64.
Please see the attached print screen.
Attached image Firefox 26 Linux
Attached image Windows XP FF26
Tested on Windows XP (English and Romanian locale), the bug doesn't reproduce.
Confirm in openSUSE 13.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hmm..dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=907793 ? Guys, please confirm....
Severity: normal → major
Component: Untriaged → Layout: Text
OS: Windows 8 → All
Product: Firefox → Core
Hardware: x86_64 → All
Yes it's a duplicate. Changing <h1 lang="ro"> to <h1 lang="en"> fixes the problem.

I wonder how many fonts in the Google Font Directory are broken.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907793
You need to log in before you can comment on or make changes to this bug.