Closed Bug 951255 Opened 10 years ago Closed 10 years ago

canvasmark 3.21% regression on windows xp starting december 11th

Categories

(Testing :: Talos, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 950264

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

(In reply to Joel Maher (:jmaher) from comment #0)
> I am not sure exactly what that does, but maybe :snorp could help us figure
> it out.

It's a variety of canvas stuff. It draws some arcs, images, text, etc.
I've been trying to narrow down which part of the big patch queue would have caused this in bug 950264.  Sounds like it would be the text part of that canvasmark subtest, since setting the font on a canvas will do some style resolution.
we could easily push to try and see if that changes the numbers.  I assume we can't just back out parts of the patches.
Yes, I've identified part of the regression in but 950264 comment 1 by doing that.  Unfortunately that patch is reasonably simple and I'm not sure if there's a way it could be rewritten to help.
good news is this doesn't affect other platforms, marking as a dup of 950264
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.