Retain original source formatting does not work properly.

VERIFIED DUPLICATE of bug 87102

Status

()

P3
major
VERIFIED DUPLICATE of bug 87102
18 years ago
17 years ago

People

(Reporter: scott_mozilla, Assigned: t_mutreja)

Tracking

Trunk
mozilla0.9.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [NC])

(Reporter)

Description

18 years ago
Preferences -> Composer -> "When Saving Files" -> Retain original source
formatting does not work properly.

Rather, when saving using the option retail original source formatting instead
appears as though it ignores source formatting completely.

Also, the realm of this option appears greater than "when saving" but also while
viewing the source of your HTML document. You should probably change the bar
option to reflect this.

Scott.

Comment 1

18 years ago
-->editor
Assignee: kmcclusk → beppe
Component: Compositor → Editor
QA Contact: petersen → sujay

Comment 2

18 years ago
Anthony already has a bug on the pref being backward, but apparently it didn't
make it for 6.1. :-(
Assignee: beppe → anthonyd

Comment 3

18 years ago
getting this in 9.5 for tony
Priority: -- → P3
Target Milestone: --- → mozilla0.9.5

Comment 4

18 years ago
the wording in the pref dialog is bass-ackwards.  needs to be fixed.

anthonyd
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [NC]

Comment 5

18 years ago
--> brade
Assignee: anthonyd → brade
Status: ASSIGNED → NEW

Comment 6

18 years ago
Akkana--let's please fix this ASAP.
-->akkana
Assignee: brade → akkana
URL: N/A

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 7

17 years ago
Composer is now doing the right thing with the pref: when the prefs dialog says
"Retain original source formatting", editor.prettyprint is false, and the format
flag is not passed to the serializer (mDoFormat == PR_FALSE).  When the prefs
dialog says "Reformat ('pretty print') HTML source", editor.prettyprint is true
and the format flag is set in the flags passed to the serializer.

The serializer isn't doing the right thing with these flags, though.  When
prettyprint is off, it's dropping newlines outside the body so e.g. there's no
newline saved at the end of the file after the </html> tag (bad!)  When
prettyprint is on, it's not ignoring whitespace from the original file, so we
get a mixture of prettyprinting and original formatting.  Lots of regressions here.

Passing to the new serializer owner.
Assignee: akkana → peterv
Status: ASSIGNED → NEW

Comment 8

17 years ago
reset component
We get a lot of complaints from users of Composer on this issue.
Severity: normal → major
Component: Editor → DOM to Text Conversion
OS: Windows ME → All
Hardware: PC → All

Comment 9

17 years ago
This bug is the only thing keeping me from using composer as my primary html
developement environment.  To effectively edit html, the source has got to be
consistently formatted.
All these missed the bus/train/plane/boat/whatever. Sad.
Target Milestone: mozilla0.9.5 → mozilla0.9.6
Target Milestone: mozilla0.9.6 → mozilla0.9.7
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 11

17 years ago
-> tanu
Assignee: peterv → tmutreja
Past 0.9.8, moving forward.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 13

17 years ago
New lines outside the body are not being passed to the serializer. Looks like 
parser issue similar to bug#87102.
Assigning to harishd, marking this one as duplicate of 87102. 



*** This bug has been marked as a duplicate of 87102 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.