Closed Bug 95149 Opened 20 years ago Closed 20 years ago

The View | Page Source doesn't work well with some cgi

Categories

(SeaMonkey :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 55583

People

(Reporter: amyy, Assigned: asa)

Details

Build: 08-10 trunk build.

Steps to repro:
1. Launch browser, go: http://www.asahi.com
2. Type any word in search field, and do seach.
3. Will bring up a search result page.
4. View | Page Source.

Result:
There is no correctly page source get displayed, only one line shows:
"Search service now is in maintenancing, please wait." - in Japanese.

IE5.5 and N4.7 will display the correctly page source with same case.

Also, there is a simple test case that created by Juraj Betak when he worked on
bug 93457:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=45450

With this cgi test script I created sends "Now you see me" - if there are any
parameters sent with the request.  And "Now you don't" - if there are no
parameters sent. 

Comments from him there:
It appears to me that the view source window is making a separate new request
w/o any parameters and hence it can receive a different response that the main
browser window did. View source should not perform a new request and if it does,
it needs to send the same request parameters to the server as the form in the
main browser window did. This potentially affects all pages created in response
to a POST request.
Summary: The View | Page Source doesn't work well with some cgi → The View | Page Source doesn't work well with some cgi
Also see bug 64100.

*** This bug has been marked as a duplicate of 55583 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.