Regression: EV green lock and non-EV gray lock swapped

VERIFIED FIXED in Firefox 29

Status

()

Firefox for Android
General
--
major
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: hsivonen, Assigned: Margaret)

Tracking

({regression, reproducible})

unspecified
Firefox 29
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 unaffected, firefox28 unaffected, firefox29 verified, fennec29+)

Details

(URL)

Attachments

(1 attachment)

Steps to reproduce:
 1) Navigate to https://hsivonen.fi/ (or any non-EV https URL) in Fennec.
 2) Navigate to https://www.mozilla.org/en-US/ (or any EV https URL) in Fennec.

Actual results:
A green lock icon is shown in the location bar for the non-EV page and a gray lock for the EV page.

Expected results:
Expected the lock to be gray for non-EV and green for EV.

Updated

4 years ago
status-firefox26: --- → unaffected
status-firefox27: --- → unaffected
status-firefox28: --- → affected
status-firefox29: --- → affected
Keywords: regression, regressionwindow-wanted, reproducible
Summary: EV green lock and non-EV gray lock swapped → Regression: EV green lock and non-EV gray lock swapped
Last good revision: 1ad9af3a2ab8 (2013-12-12)
First bad revision: 8b5875dc7e31 (2013-12-13)

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1ad9af3a2ab8&tochange=8b5875dc7e31

Last good revision: f5bb944954a5
First bad revision: 800878f01d5d
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f5bb944954a5&tochange=800878f01d5d

Likely bug 943915.
Blocks: 943915
Keywords: regressionwindow-wanted
Actually probably bug 945212.
Blocks: 945212
No longer blocks: 943915
tracking-firefox28: --- → ?
tracking-firefox29: --- → ?

Updated

4 years ago
status-firefox28: affected → unaffected
tracking-firefox28: ? → ---
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 29+
(Assignee)

Comment 3

4 years ago
Created attachment 8349582 [details] [diff] [review]
patch

This problem is caused by the fact that we're using mode.ordinal() here to set the image level:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/toolbar/BrowserToolbar.java#987

But the order of items in the SecurityMode enum doesn't match the image levels in site_security_level.xml (even though there's a comment above it that says it does!).
Attachment #8349582 - Flags: review?(mark.finkle)
Attachment #8349582 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/f95fea48b259
https://hg.mozilla.org/mozilla-central/rev/f95fea48b259
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox29: affected → verified
tracking-firefox29: ? → ---
You need to log in before you can comment on or make changes to this bug.