Area around tabs (not the actual tabs) becomes transparent or 100% black (depending on whether window is maximized or not)

RESOLVED DUPLICATE of bug 656891

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 656891
5 years ago
3 years ago

People

(Reporter: ben, Unassigned)

Tracking

26 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 8349375 [details]
black.png

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

I have not been able to determine what, exactly, causes Firefox to fall into this state, but a Remote Desktop connection to the machine on which Firefox is running is a possible cause. Typically, I will just be "working along" and then notice this most annoying problem all-of-a-sudden.

An important clue may be the fact that the *exact same thing* happens in Thunderbird. Presumably, both applications use the same UI components to render the tabbed portion of the interface.


Actual results:

When Firefox falls into this "glitched state", the area *around* the tabs (and *not* the actual tabs) becomes 100% transparent. This is a usability headache because other windows show-through and easily confuse the user as to which parent window the visible tabs belong (see attached screenshots for examples).

A curious feature of this bug is that if the browser window is un-maximized, the 100% transparent area turns 100% black (see attached screenshots).

This bug occurs after some period of time during regular use (usually a day or two), and again, I haven't been able to nail-down what triggers it. It happens whether in regular browsing mode or Private browsing mode. Also, when it happens, it happens to all open Firefox windows/instances, across regular and Private sessions.

Notice that the minimize, restore and close buttons are absent when this bug occurs. In the "transparent" version of the bug (as opposed to the "black version"), the buttons that are visible at top-right actually belong to the window behind the Firefox window. I included a third screenshot of what happens when I try to click one of those buttons; out of nowhere, the Firefox window's buttons re-appear.

I don't have this type of problem with any other software, and it's no coincidence that it happens with both Firefox and Thunderbird. My video drivers are completely up-to-date, for what it's worth.

In one screenshot, I have demonstrated the effect when multiple windows are stacked on top of one another, which makes it obvious why this bug often inspires a brief "WTF" moment until I realize what has happened. The first two tabs ("Google" and "Private Browsing") are from the top-most window. The other three tabs are from the next window back in the stack, and the minimize/maximize/close buttons belong to yet a third application window in the stack.


Expected results:

The area around the tabs should not "glitch-out" like this, under any circumstance.
(Reporter)

Comment 1

5 years ago
Created attachment 8349376 [details]
transparent.png
(Reporter)

Comment 2

5 years ago
Created attachment 8349377 [details]
transparent-with-buttons.png
(Reporter)

Comment 3

5 years ago
Created attachment 8349378 [details]
with-multiple-firefox-windows-open.png

Comment 4

4 years ago
I can confirm the issue on Windows 8 x86_64, very similar results.

[firefox].................[min does work, and is not visible][max ditto]
[tab 1 - black bg, icon] ... [tab N selected, looks fine]

Tab N content
(looks fine)


Some observations, to reproduce.  I have 10 tabs open.  I have about 10 active plugins (nothing unusual).  This happens with every run.  Seems to start with trying to min/max the application, and then give up, try it by dragging from the lower right corner.  At some point the menu pane and tab bar goes black.

Comment 5

4 years ago
Once the menubar and tab bar go black, as the filer mentioned, you can no longer click the "Firefox" menu, close, min, or max.  The tabs still work.  The components still seem to be there and will reappear momentarily between a double click on the title bar, which appears to toggle between no title bar and a title bar.
(In reply to David J. Kordsmeier from comment #4)
> I can confirm the issue on Windows 8 x86_64, very similar results.
> 
> [firefox].................[min does work, and is not visible][max ditto]
> [tab 1 - black bg, icon] ... [tab N selected, looks fine]
> 
> Tab N content
> (looks fine)
> 
> 
> Some observations, to reproduce.  I have 10 tabs open.  I have about 10
> active plugins (nothing unusual).  This happens with every run.  Seems to
> start with trying to min/max the application, and then give up, try it by
> dragging from the lower right corner.  At some point the menu pane and tab
> bar goes black.
(Reporter)

Comment 6

4 years ago
A big "Thank you!" to David J. Kordsmeier for confirming this issue.

For what it's worth, this bug is still present in Firefox 32.0.
Is this the same as bug 951646?
(In reply to Botond Ballo [:botond] from comment #7)
> Is this the same as bug 951646?

Er, doh, I meant bug 656891 :)

Comment 9

3 years ago
1. I can reproduce on my machine W8.1 64 English, FF 37.0.1 - it reproduce constantly.
2. if more screenshots or environment details are required, I'll be glad to share.
3. @BotondBallo: I Can confirm that it is the same bug as 656891.
4. it seems like the issue occurs when running Remote Desktop connection while FireFox is open.
Considering https://bugzilla.mozilla.org/show_bug.cgi?id=656891#c21, setting this bug as a dupe of 656891 (for better tracking).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656891
You need to log in before you can comment on or make changes to this bug.