Closed Bug 951680 Opened 6 years ago Closed 3 years ago

Intermittent browser_alltabslistener.js | Got a notification for the front notifications listener - Got onStateChange, expected onLocationChange

Categories

(Firefox :: Tabbed Browser, defect, P3)

28 Branch
x86
Linux
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: cbook, Assigned: Gijs)

References

()

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:timing][fixed by bug 1379447])

Rev3 Fedora 12 fx-team debug test mochitest-browser-chrome on 2013-12-18 03:00:20 PST for push ae5d8b396299

slave: talos-r3-fed-067

https://tbpl.mozilla.org/php/getParsedLog.php?id=32154012&tree=Fx-Team

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_alltabslistener.js | Got a notification for the front notifications listener - Got onStateChange, expected onLocationChange
Duplicate of this bug: 951740
Disabling on Linux for too many intermittent failures.
Summary: Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_alltabslistener.js | Got a notification for the front notifications listener - Got onStateChange, expected onLocationChange → Intermittent browser_alltabslistener.js | Got a notification for the front notifications listener - Got onStateChange, expected onLocationChange
Whiteboard: [test disabled on linux] [leave open]
Bug 1101122 might have fixed this so I've re-enabled the test
Whiteboard: [test disabled on linux] [leave open] → [leave open]
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
starting on July 7th, this had an instance, then it wasn't until july 10th when this started failing in bulk- I assume due to volume of pushes we only saw a couple instances on the weekend (8th/9th).

this fails primarily on osx opt in e10s mode.

here is a recent log file:
https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-central&job_id=113068580

and related screenshot:
https://public-artifacts.taskcluster.net/W1YAHrgBTBSHbL1bNBZkRw/0/public/test_info/mozilla-test-fail-screenshot_IRkzOo.png

the data from the above log around the failure:
09:55:28     INFO - TEST-PASS | browser/base/content/test/general/browser_alltabslistener.js | onStateChange notification came from the correct browser - 
09:55:28     INFO - TEST-PASS | browser/base/content/test/general/browser_alltabslistener.js | Got an expected notification for the all notifications listener - 
09:55:28     INFO - TEST-PASS | browser/base/content/test/general/browser_alltabslistener.js | Got a notification for the all notifications listener - 
09:55:28     INFO - FrontProgress: onStateChange 0xc0010
09:55:28     INFO - TEST-PASS | browser/base/content/test/general/browser_alltabslistener.js | Got an expected notification for the front notifications listener - 
09:55:28     INFO - Buffered messages finished
09:55:28     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_alltabslistener.js | Got a notification for the front notifications listener - Got onStateChange, expected onLocationChange
09:55:28     INFO - Stack trace:
09:55:28     INFO - chrome://mochikit/content/browser-test.js:test_is:967
09:55:28     INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_alltabslistener.js:onStateChange:16
09:55:28     INFO - resource://gre/modules/RemoteAddonsParent.jsm:wrapProgressListener/get/<:968
09:55:28     INFO - chrome://browser/content/tabbrowser.xml:callListeners:492


::dao, can you help find someone to look into this bug in the next 2 weeks?  I will keep an eye on this if it gets more frequent or less frequent once/twice each week.
Flags: needinfo?(dao+bmo)
Whiteboard: [leave open] → [leave open][stockwell needswork]
Flags: needinfo?(dao+bmo)
See Also: → 1379447
Depends on: 1379447
See Also: 1379447
Joel, I think this is also fixed by bug 1379447, but I don't know how to update the stockwell whiteboard tags, so I'm flagging you for that. I'd request needinfo but it appears I can't... :-)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Whiteboard: [leave open][stockwell needswork] → [stockwell needswork][fixed by bug 1379447]
Whiteboard: [stockwell needswork][fixed by bug 1379447] → [stockwell fixed:timing][fixed by bug 1379447]
You need to log in before you can comment on or make changes to this bug.