Closed Bug 951725 Opened 6 years ago Closed 6 years ago

Save session state before switching to Metro

Categories

(Firefox for Metro Graveyard :: General, defect, P2)

x86_64
Windows 8
defect

Tracking

(firefox28 verified, firefox29 verified)

VERIFIED FIXED
Firefox 29
Tracking Status
firefox28 --- verified
firefox29 --- verified

People

(Reporter: emtwo, Assigned: emtwo)

References

Details

(Whiteboard: [beta28] p=1)

Attachments

(1 file)

Switching from desktop to metro immediately after opening a new page will not show the new page on metro since the state isn't saved before switching.
Assignee: nobody → msamuel
Blocks: 924886
Whiteboard: p=1
Blocks: metrov1it21
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: p=1 → [beta28] p=1
Comment on attachment 8349478 [details] [diff] [review]
v1: Notify sessionstore of browser restart in order to save session state.

Review of attachment 8349478 [details] [diff] [review]:
-----------------------------------------------------------------

Adding Tim Taubert as a Firefox peer reviewer.
Attachment #8349478 - Flags: review?(ttaubert)
Attachment #8349478 - Flags: review?(mbrubeck)
Attachment #8349478 - Flags: review+
Attachment #8349478 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/integration/fx-team/rev/9ef88383852a
Whiteboard: [beta28] p=1 → [fixed-in-fx-team][beta28] p=1
https://hg.mozilla.org/mozilla-central/rev/9ef88383852a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][beta28] p=1 → [beta28] p=1
Target Milestone: --- → Firefox 29
Comment on attachment 8349478 [details] [diff] [review]
v1: Notify sessionstore of browser restart in order to save session state.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Part of bug 924860

User impact if declined: Opening a new tab in Desktop Firefox and immediately switching to Metro will result in that tab not showing. (Same with closing a tab, clicking a link, etc)

Testing completed (on m-c, etc.): Tested and works on mc

Risk to taking this patch (and alternatives if risky): Low risk, it only affects the switch-to-metro code and is a minor change

String or IDL/UUID changes made by this patch: none
Attachment #8349478 - Flags: approval-mozilla-aurora?
Attachment #8349478 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

Verified on latest nightly (build ID: 20140108030203) and on latest aurora (build ID: 20140108004006).
Switching from desktop to metro immediately after opening a new page will show the new page on metro and same for closing a page and switching to metro (the page will not be shown).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.