Closed Bug 951756 Opened 8 years ago Closed 8 years ago

[B2G][Browser][Youtube] Youtube videos with multiple closed caption subtitles automatically play the last available subtitle file

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.2 unaffected, b2g-v1.3 affected)

RESOLVED FIXED
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- affected

People

(Reporter: bzumwalt, Assigned: fzzzy)

References

Details

(Keywords: regression)

Attachments

(2 files)

Description:
Playing a Youtube video in the browser with subtitles in multiple languages, subtitles display automatically. The closed caption language displayed is the last language listed alphabetically (i.e. In a list of English, Italian, Vietnamese, and German subtitles, the language displayed would be Vietnamese.) There does not appear to be any option to disable, or change the language of these subtitles in the browser, though the option does exist when viewing same videos on computer.

Repro Steps:
1) Updated Buri to Build ID: 20131218004002
2) Open Browser app
3) Navigate to Youtube.com
4) Search "Google Zeitgeist 2013" (or any video with multiple closed caption subtitles)
5) Play video

Actual:
Youtube videos with multiple subtitles automatically display last language available.

Expected:
Youtube videos do not automatically display closed captions.

Environmental Variables
Device: Buri v 1.2 COM RIL
Build ID: 20131218004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/369bdbff6c38
Gaia: a99b23e73fe5630a877004746d0e7fcec1b6d653
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115


Notes:
Repro frequency: 3/3, 100%
See attached: screenshots
Optional extra notes:
Videos tested - The Great Dictator - Charlie Chaplin (Multi-language Subtitles)[http://www.youtube.com/watch?v=b8_FXu6hgfM] & Google Zeitgeist | Here's to 2013 [http://www.youtube.com/watch?v=Lv-sY_z8MNs]
Environmental Variables Device line for above should read: Buri v 1.3 MOZ RIL
Issue does NOT reproduce on 1.2

Result: Youtube videos do not automatically display closed captions.

Environmental Variables
Device: Buri v 1.2 COM RIL
Build ID: 20131218004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/dcffefec8206
Gaia: 38338b31b554cdb8c6242b15a966f171a0e7abaa
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115
Confused with comment 3 vs. comment 0 - are you saying that the expected behavior works correctly on 1.2, and fails on 1.3?
Flags: needinfo?(bzumwalt)
Issue occurs on 1.3

Issue does NOT occur on 1.2

See Comment 1 for corrections to Comment 0
Flags: needinfo?(bzumwalt)
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → Video/Audio
Product: Firefox OS → Core
Version: unspecified → 28 Branch
blocking+ for regression with a target partner app
blocking-b2g: 1.3? → 1.3+
Keywords: regression
Anthony, do you know who'd be a good person for this bug?
Flags: needinfo?(ajones)
This issue started reproducing on the 12/03/13 1.3 build.

- Works -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131202092621
Gaia: 8527840366eec3252d04e0dad64e7a40dbe3dc56
Gecko: 2581b84e0ca1
Version: 28.0a1
Firmware Version: V1.2_US_20131115

- Broken -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131203040236
Gaia: 31808a29cfcffa584b6a88b4f1e515387f485a1b
Gecko: 8648aa476eef
Version: 28.0a1
Firmware Version: V1.2_US_20131115
QA Contact: jzimbrick
QA Contact: jzimbrick
1.3 has native webvtt support through the <track> element, which 1.2 did not. That might be the difference. Off the top of my head we're either not handling default properly, or it's a youtube bug.
Flags: needinfo?(ajones)
Assignee: nobody → rick.eyre
If it's working on Firefox properly I would assume it's a Youtube bug. Possibly they're using our native implementation for whatever reason on B2G, which isn't ready yet. Hence, there is no UI to change subtitles and the last language is played because that's the order they're loaded in.

I'll look into it more closely.
Rick, have you confirmed if this is a YouTube bug?
Flags: needinfo?(rick.eyre)
(In reply to Peter Dolanjski [:pdol] from comment #11)
> Rick, have you confirmed if this is a YouTube bug?

One addition to this from an offline discussion - we need firm evidence of why this is or isn't a gecko bug. If we get firm evidence that it isn't a gecko bug, then the content team can outreach to YT to fix the bug.
(In reply to Peter Dolanjski [:pdol] from comment #11)
> Rick, have you confirmed if this is a YouTube bug?

Not yet. Sorry it's taken me a while to get to this. I'll be able to take a look at it early next week.

(In reply to Jason Smith [:jsmith] from comment #12)
> (In reply to Peter Dolanjski [:pdol] from comment #11)
> > Rick, have you confirmed if this is a YouTube bug?
> 
> One addition to this from an offline discussion - we need firm evidence of
> why this is or isn't a gecko bug. If we get firm evidence that it isn't a
> gecko bug, then the content team can outreach to YT to fix the bug.

Sounds good. I'll make sure to get some hard evidence.
Flags: needinfo?(rick.eyre)
Looking at the screenshots I would say that it is because YouTube is using our WebVTT implementation, which they shouldn't (at least not yet). We _were_ using the incorrect CSS styling on our subtitles (recently changed by a patch), which is what those screen shots are showing. If you go and look at YouTube subtitles on FF desktop, where they work, you'll see that the subtitles are white on a black background. Whereas, our previously incorrect CSS styling is white text, no background, with text-shadow.

Do you need harder evidence then that Jason? We were the only browser using that particular styling so I would say with pretty good confidence that it is a YouTube bug, since they're using our implementation when it's not ready yet. I'll go look at code early next week if you need some harder evidence then that.
Flags: needinfo?(jsmith)
Okay - sounds good. I'll move this over to the TE component & will outreach to YT to fix this.
Assignee: rick.eyre → nobody
Blocks: b2g-youtube
blocking-b2g: 1.3+ → ---
Component: Video/Audio → Mobile
Flags: needinfo?(jsmith)
Product: Core → Tech Evangelism
Version: 28 Branch → unspecified
Component: Mobile → Preinstalled B2G Apps
What's the status?
Assignee: nobody → dpreston
Status: NEW → ASSIGNED
Priority: -- → P2
To clarify, I'd say YouTube is welcome to use our native webvtt display if it works for them. But we don't have controls for switching subtitles on/off yet, so they need to be controlling that properly. That's the actual bug.
I will mention this to YT in our next meeting.
I think YT fixed this as I can't reproduce it on any of the devices I have here. I would like to double check on Buri 1.3 though. Nicole, did you get the Buri back from Harald yet? Can you test this for me?
Flags: needinfo?(nfong)
Unable to reproduce on Buri v1.3. Changing status to Resolved-Fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Flags: needinfo?(nfong)
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.