Closed Bug 951982 Opened 9 years ago Closed 9 years ago

about:accounts page should indicate if email is unverified

Categories

(Cloud Services :: Server: Firefox Accounts, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: markh, Assigned: rfkelly)

References

Details

(Whiteboard: [qa+])

If sync is configured to use fxaccounts, the system doesn't recognise the account, leading to the following situation:

* Go to Sync Options - the options dialog thinks no user is configured so offers to allow you to "setup sync"

* You select this and about:accounts opens.  However, this tells you that you are already logged in.

* But Sync fails to work.  These steps repeat ad-nauseum - ie, sync itself tells you things are not setup, and about:accounts tells you it is, and sync silently does anything.

The problem is simply that the email address is not verified.  A good first-step at reducing this confusion would be for about:accounts to tell you that although you are logged in, the email is not verified so your FxAccount isn't going to work.

(Later we will need something better than even this - ie, the sync dialog should detect this case, but this seems like a reasonable interim solution)
Whiteboard: [qa+]
FTR - if you create an account using about:accounts, the "email needs verification" page *does* display (although see also bug 956605).  This bug only happens if Firefox is restarted before verification happens (and possibly if about:accounts is manually refreshed)
Any updates on this?  For some reason my previously verified accounts seem to be getting into an unverified state, which causes hard to diagnose failures logging into Sync, and seems impossible to fix as there is no exposed way to request a resend of the verification email.
UI has been simplified to avoid showing about:accounts in the unverified state.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Awesome.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.