Status

()

Core
XPCOM
P3
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: sh990154, Assigned: John Bandhauer)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I'm going to port mozilla / Seamonkey to the ARM architecture.
There are some problems I have with some inline assembly in
xpcom/reflect/xptcall/src/md/unix/xptcstubs*
I'm not that used to other processors assembly language/compiler procedure
calling standards.
It would be good to know what the exact purpose of that inline assembler code
is and from where it gets called (to know what parameters are passed in which
registers.)

Updated

19 years ago
Assignee: dp → mccabe

Comment 1

19 years ago
The assembly code in xptcall provides general facilities for:

- Implementing an XPCOM interface dynamically, with arbitrary code behind it
(potentially JavaScript or Java)

- Calling XPCOM interfaces dynamically, e.g. from another language such as
JavaScript.

xptcall is currently used by XPConnect, to script XPCOM interfaces directly from
JavaScript, and by proxy, to dynamically call interfaces across thread
boundaries.  Due to the nature of what it does, xptcall steps outside the
boundaries of what is possible in portable C++, and so must include (a *tiny*
bit of) per-platform assembly code.

There's a porting FAQ and porting status guide available; start at the xptcall
Porting Status page:

http://lxr.mozilla.org/mozilla/source/xpcom/reflect/xptcall/status.html

This page shows somebody looking at the xptcall port for the ARM, but it's not
clear that they've done anything; it'd probably be worth getting in touch with
them if you'd like to take a look.  If you do, it'd probably be best if you
reassigned this bug to yourself.

Good luck!

cc'ing jband, briano as possibly-interested parties.

Updated

19 years ago
Assignee: mccabe → jband

Comment 2

19 years ago
John Bandhauer has been working with the reporter on this one; reassigning.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
I'm just marking this fixed. I think that the information request has been
satisfied via email

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
since the conversation via email ersolved this -- marking this as verified.

Comment 5

18 years ago
*** Bug 40422 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
ignore that last dup from me, it's a typo (and I fixed it) supposed to be 39520
You need to log in before you can comment on or make changes to this bug.