Closed Bug 952103 Opened 9 years ago Closed 9 years ago

"Sorry, there was a problem" error is displayed when the Buy button is pressed for a paid app

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

Other
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: julian.mozbugs, Assigned: jorgev)

References

Details

Attachments

(2 files)

Region code: Moss and Hanger
Device: Galaxy Nexus
Connection: WiFi and Data
Phone number/MSISDN: 639411905
Carrier: Movistar
Last 4 digits CC:
Test App used: Test App (c0k7)

steps to reproduce:
1. Load MP-stage on Android device https://marketplace.allizom.org/
2. Search for a PAID app.
3. Try to purchase a paid app.

expected behavior:
The app is successfully purchased.

observed behavior:
"Sorry, there was a problem. Please try again later." message is displayed.

Notes/Issues:
Verified on FF29 (Android 4.2.1)
Log ID:739ef
Reproducible also on FF OS device. Rafael confirmed same behavior on Hanger.
Severity: normal → critical
I can't reproduce and can't find a matching error log on our end. Was there anything in the logs at your end? Logs or screenshots so we know where to look would help.
Severity: critical → normal
Attached image android payment.png
Assigning to Bango, its on the Bango payment page.
Assignee: nobody → tom
Blocks: 909896
rafael or iulian, 

please attach the logcat for this issue. Thanks!
Attached file nexus bango Logcat.txt
This is not a Bango error. We are showing an error message due to BLueVia / local country returning ERROR ERROR to us.

Reassigning this to Jorge Vila for investigation.

Jorge, Bango are passing you the request to charge the user but we are receiving an ERROR ERROR back every time for Spain and on occasions for Hungary.

Can you investigate on your side please.

Hungary attempts:
19 Dec 13 15:09:31 pricetier4	ERROR
19 Dec 13 14:29:43 pricetier4	ERROR
19 Dec 13 14:18:10 pricetier6	ERROR
19 Dec 13 13:43:18 pricetier1	ERROR
19 Dec 13 13:41:06 PriceTier1	ERROR	

Spain attempts:
20 Dec 13 08:31:44 Test App (c0k7)ERROR
20 Dec 13 08:31:44 Test App (c0k7)ERROR
20 Dec 13 08:25:22 Test App (c0k7)ERROR
20 Dec 13 08:25:22 Test App (c0k7)ERROR
19 Dec 13 17:12:01 Android Test (skunk)	ERROR
19 Dec 13 15:46:25 pricetier6 ERROR
19 Dec 13 15:01:33 pricetier6 ERROR
19 Dec 13 15:00:26 Test App (sfsdfsdfsdfd)ERROR
19 Dec 13 14:38:43 Test App (c0k7)ERROR
Assignee: tom → jorgev
Hi,

I am currently on christmas holidays. I have sent your request to our 24x7 support at globalsts@telefonica.es

Please, contact them to follow up on any production live issue.

Best regards
JORGE
Version: 1.4 → 1.5
Do we know if anyone sent this to Telefonica support?
Flags: affects-moss+
Flags: affects-hanger+
Hi Andy,

I passed it when already in holidays. Could you please confirm whether it is failing?

When I received the error, I thought it was due to connectivity or something like that. But, watching the transactions, you can see it is working or giving proper errors, like Insufficient balance.

Please, verify.

Best
JORGE

MSISDN;OPERATION;STATUS;FINAL?;REFUNDED?;TX_TRANSACTION_ID;GROSS;NET;CURRENCY;NET?;TAX?;TOTAL?;PRICE_POINT_REF;TX_REQUEST_AMOUNT_DESC;ELAPSEDINMILIS;TS_REQUEST;TX_APP_PROVIDER;NU_CLIENT_OB_ID;NU_CLIENT_COUNTRY_ID;TX_APPLICATION_ID;ERR_CODE;ERR_MSG;RESULT_CODE;RESULT_CODE_DESC

tel:34638003163;Charge;Capture;;Yes;28234f74-7986-44ee-9fde-c5cf1a00412a;-;0.01;EUR;Yes;No;No;;TEST;2077;18/12/2013 09:48:10,342;50098;1;1;50029;;;OK;Transaction Phase Successful

tel:34638003163;Refund;Refunded;;-;8791f5a7-909e-41d8-b042-f3a195be98da;-;-0.01;EUR;No;No;No;;TEST;1043;18/12/2013 09:49:47,725;50098;1;1;50029;;;OK;Refund Phase Successful

tel:34682061467;Charge;Fail;Fail;Not;70c36177-3eba-44b1-8535-887e788b5468;-;0.01;EUR;Yes;No;No;;TEST;1060;18/12/2013 09:51:58,311;50098;1;1;50029;SVR1000;Generic Server Error:;ERR_0007_ERR_9996;ERR_0007|ERR_9996|Wrong customer

tel:+34639268364;Charge;Capture;;Not;245d5cd4-c877-45d0-8a02-54185f6f2986;-;0.37;EUR;Yes;No;No;;Mozilla - Text him?;3013;18/12/2013 15:08:11,709;50098;1;1;50029;;;OK;Transaction Phase Successful

tel:+34639311207;Charge;Fail;Fail;Not;042c9e32-9734-47e1-8dc2-8ff7f31162b1;-;0.74;EUR;Yes;No;No;;Mozilla - Test App (iupsbfodawsp);1071;18/12/2013 19:54:30,309;50098;1;1;50029;SVC3705;Insufficient payment method balance:;ERR_0001_ERR_0408;ERR_0001|ERR_0408|Insufficient prepaid balance

tel:+34639311207;Charge;Fail;Fail;Not;60953ed8-f149-4277-983c-e9a069f2171e;-;0.74;EUR;Yes;No;No;;Mozilla - Test App (iupsbfodawsp);1033;18/12/2013 19:54:59,206;50098;1;1;50029;SVC3705;Insufficient payment method balance:;ERR_0001_ERR_0408;ERR_0001|ERR_0408|Insufficient prepaid balance

tel:+34628661469;Charge;Capture;;Not;6c43a461-3005-46fb-88d8-8e9f41b88e16;-;0.74;EUR;Yes;No;No;;Mozilla - Test App (c0k7);3042;20/12/2013 19:37:05,516;50098;1;1;50029;;;OK;Transaction Phase Successful

tel:+34648938379;Charge;Fail;Fail;Not;eff519d2-9568-453d-9fb5-2a9b80c472de;-;0.74;EUR;Yes;No;No;;Mozilla - OrbLand;4061;22/12/2013 15:37:47,023;50098;1;1;50029;SVC3705;Insufficient payment method balance:;ERR_0001_ERR_0408;ERR_0001|ERR_0408|Insufficient prepaid balance

tel:+34648938379;Charge;Fail;Fail;Not;97cd2796-c3a2-4a2b-821d-f0be813ffd98;-;0.74;EUR;Yes;No;No;;Mozilla - OrbLand;2016;22/12/2013 15:38:10,946;50098;1;1;50029;SVC3705;Insufficient payment method balance:;ERR_0001_ERR_0408;ERR_0001|ERR_0408|Insufficient prepaid balance

tel:+34648940656;Charge;Fail;Fail;Not;1c007c45-56dc-4acc-9d50-c9617b1024fc;-;0.74;EUR;Yes;No;No;;Mozilla - OrbLand;2028;27/12/2013 16:51:33,730;50098;1;1;50029;SVC3705;Insufficient payment method balance:;ERR_0001_ERR_0408;ERR_0001|ERR_0408|Insufficient prepaid balance

tel:+34648940656;Charge;Fail;Fail;Not;7857fdfa-9f96-44de-950c-255a930882a6;-;0.74;EUR;Yes;No;No;;Mozilla - OrbLand;1059;27/12/2013 16:51:46,597;50098;1;1;50029;SVC3705;Insufficient payment method balance:;ERR_0001_ERR_0408;ERR_0001|ERR_0408|Insufficient prepaid balance

tel:+34629386739;Charge;Capture;;Not;35cfbd45-8f04-417c-a1ca-ca0a1b180514;-;0.21;EUR;Yes;No;No;;Mozilla - Stop IT!;7003;04/01/2014 20:07:07,667;50098;1;1;50029;;;OK;Transaction Phase Successful
We'll need a tester in country to try it.
Flags: needinfo?(iulian.timis)
I was able to purchase the app, the issue is no longer reproducing.
Flags: needinfo?(iulian.timis)
i am closing if this is no longer reproducible
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.