nsIDOMWindowUtils#sendTextEvent is undefined

RESOLVED DUPLICATE of bug 911951

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 911951
4 years ago
4 years ago

People

(Reporter: Florent Fayolle, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

1. Open Scratchpad (SHIFT+F4)
2. Change the Environment to Browser
3. Enter this expression:
window.QueryInterface(Components.interfaces.nsIInterfaceRequestor).
                 getInterface(Components.interfaces.nsIDOMWindowUtils).sendTextEvent
4. Evaluate with CTRL-L


Actual results:

The result of the expression is "undefined". 
But according to the documentation, the method should exist:
https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/nsIDOMWindowUtils#sendTextEvent%28%29
(Reporter)

Comment 1

4 years ago
My apologies, the function has actually been replaced by createCompositionStringSynthesizer(). See https://bugzilla.mozilla.org/show_bug.cgi?id=911951#c31

Florent
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911951
You need to log in before you can comment on or make changes to this bug.