Enable MessagePort/MessageChannel by default

RESOLVED FIXED in Firefox 41

Status

()

Core
DOM
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: baku, Assigned: baku)

Tracking

({dev-doc-complete, feature})

Trunk
mozilla41
dev-doc-complete, feature
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox41 fixed, relnote-firefox -)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Comment hidden (empty)

Updated

3 years ago
Keywords: feature, relnote
OS: Linux → All
Hardware: x86_64 → All
Keywords: dev-doc-needed
Keywords: relnote
(Assignee)

Comment 1

3 years ago
Created attachment 8514968 [details] [diff] [review]
enabled.patch

We cannot land this patch until MessagePort in Workers is landed
Attachment #8514968 - Flags: review?(bugs)
(Assignee)

Updated

3 years ago
Assignee: nobody → amarchesini

Comment 2

3 years ago
I wonder if we should have one extra cycle MessageChannel enabled in non-release, but disabled in beta/release. 
At least this shouldn't land any time close to the next merge.


So, (assuming bug 911972 gets fixed before the next merge) could we land this patch right 
_after_ the next merge, but land a patch which enables MessagePort/Channel for non-release branches by default before the merge.

Comment 3

3 years ago
Comment on attachment 8514968 [details] [diff] [review]
enabled.patch

I think we should not yet remove the pref, but we should just
set the pref enabled by default in all.js.
Easier and safer to just set the pref false if we see regressions in aurora or beta.

And as long as we have the pref, tests should explicitly set it.
Attachment #8514968 - Flags: review?(bugs) → review-
(Assignee)

Comment 4

3 years ago
Created attachment 8515896 [details] [diff] [review]
enabled.patch
Attachment #8514968 - Attachment is obsolete: true
Attachment #8515896 - Flags: review?(bugs)

Comment 5

3 years ago
Comment on attachment 8515896 [details] [diff] [review]
enabled.patch

(new patch coming)
Attachment #8515896 - Flags: review?(bugs)
(Assignee)

Comment 6

3 years ago
Created attachment 8515914 [details] [diff] [review]
enabled.patch
Attachment #8515896 - Attachment is obsolete: true
Attachment #8515914 - Flags: review?(bugs)

Updated

3 years ago
Attachment #8515914 - Flags: review?(bugs) → review+
:baku, any reason that this hasn't landed yet?

Comment 8

2 years ago
See comment 1
Comment 1 does not explain why, so: why is this still turned off by default, instead of turned on so that at least in regular JS context we can make use of MessageChannel (with the webworker implementation landing in some future update, if ever, if the progress on this is any indication)? 

We patched this in 2012, it's now 2015, we're dragging our feet to a ridiculous degree given that the code to support this functionality has already landed. Let's at least get us to "partial support" instead of "not available despite the code already being in place".
Blocks: 1174303
(Assignee)

Comment 10

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/bd11384b3241
(Assignee)

Comment 11

2 years ago
Created attachment 8622547 [details] [diff] [review]
MessageChannel exposed interface to workers
Attachment #8622547 - Flags: review?(bugs)

Updated

2 years ago
Attachment #8622547 - Flags: review?(bugs) → review+
(Assignee)

Comment 12

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/465dfc26cccb
Backed out because bug 911972 was backed out.
https://hg.mozilla.org/integration/mozilla-inbound/rev/79e11098d70a
Also, test failures after this bug landed:
https://treeherder.mozilla.org/logviewer.html#?job_id=10784754&repo=mozilla-inbound
And https://treeherder.mozilla.org/logviewer.html#?job_id=10786236&repo=mozilla-inbound
This also had test_interfaces.html failures remaining after the follow-up from comment 12 landed. Please verify that this is green across the board on Try before attempting to push again.
https://treeherder.mozilla.org/logviewer.html#?job_id=10787165&repo=mozilla-inbound
(Assignee)

Comment 17

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/27b0d2176ef1
https://hg.mozilla.org/mozilla-central/rev/27b0d2176ef1
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Depends on: 1177727

Comment 19

2 years ago
For reference, I edited https://developer.mozilla.org/en-US/docs/Web/API/MessageChannel to indicate that this is available on Firefox 41 and Firefox Mobile 41 (not sure about version number for Firefox OS).
Thanks Wladimir, I've added the info in the subpages compat table and I have update Firefox 41 for developers:
https://developer.mozilla.org/en-US/Firefox/Releases/41#InterfacesAPIsDOM
Keywords: dev-doc-needed → dev-doc-complete

Comment 21

2 years ago
Release Note Request (optional, but appreciated)
[Why is this notable]: easier/better cross-thread communication for webdevs
[Suggested wording]: Implemented HTML5 MessagePort & MessageChannel APIs
[Links (documentation, blog post, etc)]: https://developer.mozilla.org/en-US/docs/Web/API/Channel_Messaging_API & https://developer.mozilla.org/en-US/docs/Web/API/MessageChannel
relnote-firefox: --- → ?
Added to FF41 release notes in Nucleus.
relnote-firefox: ? → 41+
Removed relnote tracking on this bug as the MessagePort and MessageChannel API has already been relnoted in bug 911972. Please let me know if these two bugs are not the same.
relnote-firefox: 41+ → -
You need to log in before you can comment on or make changes to this bug.