GeckoView Library does not contain resources any more? It throws ResourceNotFoundExecption.

RESOLVED DUPLICATE of bug 951865

Status

()

RESOLVED DUPLICATE of bug 951865
5 years ago
5 years ago

People

(Reporter: admin, Unassigned)

Tracking

29 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

I compiled geckoview for android. 


Actual results:

It contain only a strings.xml for en-US. And when I use it as a library, app throws ResourceNotFoundException on GeckoView::<init>, getColor.
I think it needs some more xml files. Where can I found it?

Even nightly build does not conatins.

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/


Expected results:

It must contain some more xmls
Perhaps related to bug 951865?
This is the same thing as Bug 951865, I think.  Further comments on that ticket.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Potential workaround if you don't need to work on the GeckoView source and are using it as a library: download the apk/assets from [1], and continue to follow the instructions via [2].

[1]: https://people.mozilla.org/~mfinkle/geckoview/
[2]: https://wiki.mozilla.org/Mobile/GeckoView#Using_GeckoView
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951865
You need to log in before you can comment on or make changes to this bug.