[Contacts][Bluetooth] "Export to Bluetooth" message blocks the Contacts app and leaves it unusable

VERIFIED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: gtorodelvalle, Assigned: gtorodelvalle)

Tracking

({regression})

unspecified
1.3 C1/1.4 S1(20dec)
x86
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

Attachments

(2 attachments)

STR:
1. Open the Contacts app having at least 1 contact in the list.
2. Click on the settings button.
3. Click on the "Export Contacts" button.
4. Click on the "Bluetooth" button.
5. Select at least 1 contact.
6. Click on the "Export" button.

OBSERVED:
7. The "Export to Bluetooth" overlay is shown and never goes away leaving the Contacts app unusable.

EXPECTED:
7. The "Export to Bluetooth" overlay is shown and it is closed to continue with the contacts exporting process.
Assignee: nobody → gtorodelvalle

Comment 1

5 years ago
Created attachment 8350584 [details]
Export to Bluetooth screen

Updated

5 years ago
Keywords: regression
BTW, it does happen in master (Gecko-56d9fc8 and latest Gaia from master) as well as in 1.3 (Gecko-ba8ed3a and latest Gaia from 1.3).

Checking with Noemí and Mari Ángeles if it should be nominated :-)
regression so nominating it to 1.3?
blocking-b2g: --- → 1.3?
Created attachment 8350600 [details]
14897.html
Attachment #8350600 - Flags: review?(jmcf)
Attachment #8350600 - Flags: feedback?(fernando.campo)

Comment 5

5 years ago
Comment on attachment 8350600 [details]
14897.html

good work, thanks!
Attachment #8350600 - Flags: review?(jmcf)
Attachment #8350600 - Flags: review+
Attachment #8350600 - Flags: feedback?(fernando.campo)
Attachment #8350600 - Flags: feedback+
status-b2g-v1.3: --- → affected
Merged in master: https://github.com/mozilla-b2g/gaia/commit/b6e92db09234c24644cd348c7e9244daf293a2f2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
traige: regression 1.3+
blocking-b2g: 1.3? → 1.3+
Uplifted b6e92db09234c24644cd348c7e9244daf293a2f2 to:
v1.3: b0da142dd6fcd78850abaf10f8084ca00b05b705
status-b2g-v1.3: affected → fixed
Duplicate of this bug: 952212
Tested and verified
1.3
Gecko 8f14407
Gaia  c3b1232
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.