SessionStore should only watch for top-level pageshow events

RESOLVED FIXED in Firefox 27

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 29
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox27 fixed, firefox28 fixed, firefox29 fixed)

Details

Attachments

(1 attachment)

Created attachment 8350615 [details] [diff] [review]
Top-level pageshow only v0.1

Desktop and Metro both limit the pagshow event to top-level windows/documents. We used to when we created the session store code Metro now uses. We lost it in the port.

I noticed this because SessionStore.onTabLoad was showing up in cnn.com pageload profiles.
Attachment #8350615 - Flags: review?(wjohnston)
Attachment #8350615 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/659ceeeb6ff9
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
(Assignee)

Updated

5 years ago
Blocks: 947390
Comment on attachment 8350615 [details] [diff] [review]
Top-level pageshow only v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Reduces the amount of times session is saved during a pageload. It should only happen once, but without this patch it can happen for iframes too.

User impact if declined: Just a possible performance issue.
Testing completed (on m-c, etc.): It's been on m-c for a while
Risk to taking this patch (and alternatives if risky): Low risk
String or IDL/UUID changes made by this patch: None
Attachment #8350615 - Flags: approval-mozilla-beta?
Attachment #8350615 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #8350615 - Flags: approval-mozilla-beta?
Attachment #8350615 - Flags: approval-mozilla-beta+
Attachment #8350615 - Flags: approval-mozilla-aurora?
Attachment #8350615 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/a990d28d924e
https://hg.mozilla.org/releases/mozilla-beta/rev/a4ceb800b3dc
Assignee: nobody → mark.finkle
status-firefox27: --- → fixed
status-firefox28: --- → fixed
status-firefox29: --- → fixed
You need to log in before you can comment on or make changes to this bug.