Can not delete Rejected App from My Submissions

RESOLVED INVALID

Status

Marketplace
Developer Pages
P4
normal
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: ramd, Unassigned)

Tracking

Points:
---

Details

(Whiteboard: [contribute][repoman])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131212030202

Steps to reproduce:

I have an app which is rejected, I want to delete/remove it from 'My Submission'.


Actual results:

I didn't find any options from where I can delete it. 


Expected results:

'Delete App' option should appear in 'Status' tab.

Comment 1

4 years ago
Hello Ram,
Your problem can be solved here.
step1: sign in on https://marketplace.firefox.com
step2:Goto Developers tab..
step3:Sign in there.
step4:After sign in, Developers->My Submissions->your app->Status & Versions.
Hope this will solve your problem.
Thanks,
Dyvik.
(Reporter)

Comment 2

4 years ago
Created attachment 8351109 [details]
delete bug.PNG

Hi Dyvik, Please notice that I was talking about "Rejected App". we dont get "Status & Version" tab there, but its just "Status" tab. And this does not have "Delete App" option. Kindly check out the screenshot here.
Flags: needinfo?(dyvik100)

Comment 3

4 years ago
Created attachment 8351179 [details]
delete.JPG

Ram,
Check this out!
Flags: needinfo?(dyvik100)
(Reporter)

Comment 4

4 years ago
Dyvik, i forgot to mention that my app was "Hosted App", and as shown in the comment 2, I am not getting option to delete this app now.

Comment 5

4 years ago
Ram,
Oh i have no idea on hosted apps :(.
Sounds like this is just a wrong conditional in the template.  Marking as contribute since I think this would be easy
Priority: -- → P4
Whiteboard: [contribute]

Comment 7

4 years ago
Created attachment 8361395 [details]
rejected_app_deletion.png

I have not been able to replicate this in a development environment yet.

Here is my method:
1) Submit a new hosted app
2) Go to reviewer tools and reject the app
3) Go back to My Submissions and click on Status
4) A delete option is listed at the bottom of the status page as shown in the screenshot

I'm not sure if I am understanding the bug correctly, any thoughts?
(Reporter)

Comment 8

4 years ago
Thanks Andrew.
 If its not the case with you then this may be problem with the one app only specifically. The app is 'flames' and I can't see delete option on https://marketplace.firefox.com/developers/app/flames/status. 

Kindly let me know to whom should I contact so the he/she can manually set some option to delete it, if possible.

Updated

3 years ago
Whiteboard: [contribute] → [contribute][repoman]

Comment 9

3 years ago
This is because you are not listed as the owner of the app, you are listed as a developer.

You'll have to ask pritybhudolia to make you an owner.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.