Closed Bug 952591 Opened 9 years ago Closed 9 years ago

[Messages] Selecting 'Send email' from a message that contains an email address does not launch Email app.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed

People

(Reporter: astole, Assigned: rwaldron)

References

Details

(Keywords: regression, Whiteboard: burirun1.3-1, burirun1.3-2)

Attachments

(2 files)

Attached video Video
Selecting the 'Send email' option from a SMS that contains an email address does not do anything. After selecting 'Send email', the menu closes and brings the user back to the SMS conversation screen.

Repro Steps:
1) Updated Buri to BuildID: 20131220004001
2) From Device A, send a SMS that contains an email address to Device B
3) Open Device A conversation screen and tap on the email address
4) Select 'Send email'

Actual:
Tapping on 'Send email' brings the user back to the SMS conversation screen instead of the Email app.

Expected:
The user is brought to the Email app.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131220004001
Gaia: ee5560ab86103701a5d046ef31d46e6c1e026355
Gecko: 40c4cb09bce5
Version: 28.0a2
Firmware Version: V1.2_20131115

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/7169/
See attached: Video
This issue does not occur in v1.2. The Email app opens as expected.

Device: Buri v1.2 Mozilla RIL
BuildID: 20131218004002
Gaia: 38338b31b554cdb8c6242b15a966f171a0e7abaa
Gecko: dcffefec8206
Version: 26.0
Firmware Version: V1.2_20131115
QA Contact: mvaughan
This issue started reproducing on the Buri 10/25 1.3 MOZ RIL build. It looks like this started occurring when a separate menu was implemented which gives the user choices regarding what to do with the email address.

- Works -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131024154023
Gaia: 2feebdb1a2583928f32407d76d798f8654621e2b
Gecko: 19fd3388c372
Version: 27.0a1
Firmware Version: 20131115

- Broken -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131025100746
Gaia: afbf45f26a73b7cd5e0a831bea48087331975286
Gecko: 2f2a45f04e7c
Version: 27.0a1
Firmware Version: 20131115
Summary: [B2G][SMS]Selecting 'Send email' from a SMS that contains an email address does not launch Email app. → [Messages] Selecting 'Send email' from a message that contains an email address does not launch Email app.
Assignee: nobody → waldron.rick
Appears to be something wrong with the Activity that gets created:

  Content JS WARN at app://sms.gaiamobile.org/js/activity_picker.js:11 in tryActivity/onerror: Unhandled error spawning activity; undefined
I'm going to reassign to julienw for now, since he worked on the commit cited above and may have a better insight here.
Assignee: waldron.rick → felash
blocking-b2g: --- → 1.3?
seeing [1], frankly, I don't know how this ever worked. The wrong method is called ("dial" instead of "email").

Rick, can you take the bug back?

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/js/thread_ui.js#L2425-L2433
Assignee: felash → waldron.rick
nit fixed

landed on gaia master https://github.com/mozilla-b2g/gaia/commit/a9238975daee10ee5c20e703db0cfee76ae6a7ea
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 957013
triage: 1.3+ for a broken feature
blocking-b2g: 1.3? → 1.3+
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x  a9238975daee10ee5c20e703db0cfee76ae6a7ea
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(waldron.rick)
(In reply to John Ford [:jhford] -- please use 'needinfo?' instead of a CC from comment #12)
> I was not able to uplift this bug to v1.3.  If this bug has dependencies
> which are not marked in this bug, please comment on this bug.  If this bug
> depends on patches that aren't approved for v1.3, we need to re-evaluate the
> approval.  Otherwise, if this is just a merge conflict, you might be able to
> resolve it with:
> 
>   git checkout v1.3
>   git cherry-pick -x  a9238975daee10ee5c20e703db0cfee76ae6a7ea
>   <RESOLVE MERGE CONFLICTS>
>   git commit

Looks like I don't have permission to push to that branch.

https://github.com/mozilla-b2g/gaia/pull/15181
Flags: needinfo?(waldron.rick)
Yep, the tree was closed during some hours yesterday, but you usually can push to that branch.

v1.3: a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Environmental Variables for V1.3
Device: Buri Moz RIL
Build ID: 20140122004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/71a8786c3815
Gaia: 744fb691c2b2a25a07c5d19fabf5748ae9aba4d9
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2-device.cfg

V1.4 Master Environmentals
BuildID: 20140122040205
Gaia: 8d18b1e2fd06c84a879f99f6e8ca1f104eeacb13
Gecko: 8f4ecbf938cd
Version: 29.0a1


For this bug, If I send an email address in an SMS message when I have an active email account on the device, If long tap on the address in the SMS and select Send Email I get left at a blank white screen. With no active email set up on the device, I get taken to the email log in page.

This is the case for V1.3 AND V1.4 Master

Do you want to reopen this bug? Or do you want a new bug filed on this issue?
Whiteboard: burirun1.3-1 → burirun1.3-1, burirun1.3-2
Flags: needinfo?(felash)
That's a known bug. I think James fixed it.
Flags: needinfo?(felash) → needinfo?(jrburke)
Yes, the email blank issue is bug 962257, fixed on master now, waiting on 1.3? approval.
Flags: needinfo?(jrburke)
You need to log in before you can comment on or make changes to this bug.