Error "use of undeclared identifier" if building with macos-target=10.9

RESOLVED DUPLICATE of bug 1123356

Status

()

RESOLVED DUPLICATE of bug 1123356
5 years ago
4 years ago

People

(Reporter: Nomis101, Assigned: Nomis101)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
As noted in https://bugzilla.mozilla.org/show_bug.cgi?id=909914#c6 if building on Mac with macos-target=10.9 you see two errors.


/Volumes/Developer/mozilla-central/toolkit/crashreporter/google-breakpad/src/client/mac/crash_generation/crash_generation_server.cc:67:30: error: 
      use of undeclared identifier 'pthread_create'
  int thread_create_result = pthread_create(&server_thread_, NULL,
                             ^
/Volumes/Developer/mozilla-central/toolkit/crashreporter/google-breakpad/src/client/mac/crash_generation/crash_generation_server.cc:83:30: error: 
      use of undeclared identifier 'pthread_join'; did you mean 'pthread_kill'?
    int thread_join_result = pthread_join(server_thread_, NULL);
                             ^~~~~~~~~~~~
                             pthread_kill
/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:80:5: note: 'pthread_kill'
      declared here
int     pthread_kill(pthread_t, int);
(Assignee)

Comment 1

5 years ago
Created attachment 8350758 [details] [diff] [review]
Fix

This will fix the two errors.
Attachment #8350758 - Flags: review?(ted)
Comment on attachment 8350758 [details] [diff] [review]
Fix

Review of attachment 8350758 [details] [diff] [review]:
-----------------------------------------------------------------

I'll land this upstream for you.
Attachment #8350758 - Flags: review?(ted) → review+
(Assignee)

Comment 4

5 years ago
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #2)
> Comment on attachment 8350758 [details] [diff] [review]
> Fix
> 
> Review of attachment 8350758 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I'll land this upstream for you.
Thanks!

Comment 5

4 years ago
Sorry, I ended up rewriting this.  :-)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123356
You need to log in before you can comment on or make changes to this bug.