Closed Bug 952736 Opened 6 years ago Closed 6 years ago

"Ukrainian" typoed as "Ukranian" in the charset autodetector menu

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- unaffected
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: hsivonen, Assigned: hsivonen)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

Turns out I can't spell Ukrainian and no one else noticed, either. :-(
Blocks: 805374
Attached patch Fix spelling (obsolete) — Splinter Review
No [Australis] in the message, because the same patch applies cleanly to m-c, Holly and Aurora.

Changing the entity name to make sure non-US English locales pick up the change.
Attachment #8350883 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8350883 [details] [diff] [review]
Fix spelling

Review of attachment 8350883 [details] [diff] [review]:
-----------------------------------------------------------------

That's embarrassing. Don't know how this works with the string freeze, but we should fix this on all affected versions.
Attachment #8350883 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to Henri Sivonen (not reading bugmail until 2014-01-02) (:hsivonen) from comment #1)
> Changing the entity name to make sure non-US English locales pick up the
> change.

Is that strictly necessary? This doesn't seem to me like a typo that would cause a mistranslation.
(In reply to Gordon P. Hemsley [:GPHemsley] from comment #3)
> (In reply to Henri Sivonen (not reading bugmail until 2014-01-02)
> (:hsivonen) from comment #1)
> > Changing the entity name to make sure non-US English locales pick up the
> > change.
> 
> Is that strictly necessary? This doesn't seem to me like a typo that would
> cause a mistranslation.

AIUI whenever we change English strings, even if we believe it wouldn't require a change in non-English ones, we need to change the string ID. I've run into this before in e.g. bug 854583. Apparently some of the software translators use doesn't do well when we change the source strings without changing the IDs. I find it very confusing, maybe I still misunderstand. Axel?
Flags: needinfo?(community)
(In reply to :Gijs Kruitbosch (Unavailable Dec 19 - Jan 2) from comment #4)
> (In reply to Gordon P. Hemsley [:GPHemsley] from comment #3)
> > (In reply to Henri Sivonen (not reading bugmail until 2014-01-02)
> > (:hsivonen) from comment #1)
> > > Changing the entity name to make sure non-US English locales pick up the
> > > change.
> > 
> > Is that strictly necessary? This doesn't seem to me like a typo that would
> > cause a mistranslation.
> 
> AIUI whenever we change English strings, even if we believe it wouldn't
> require a change in non-English ones, we need to change the string ID. I've
> run into this before in e.g. bug 854583. Apparently some of the software
> translators use doesn't do well when we change the source strings without
> changing the IDs. I find it very confusing, maybe I still misunderstand.
> Axel?

Sigh at bugzilla.
Flags: needinfo?(community) → needinfo?(l10n)
You are just fixing a typo in en-US, no need to update the entity, see https://developer.mozilla.org/en-US/docs/Making_String_Changes

In bug 854583 you changed the word, so in this case updating the entity was necessary.
(In reply to :Gijs Kruitbosch (Unavailable Dec 19 - Jan 2) from comment #4)
> (In reply to Gordon P. Hemsley [:GPHemsley] from comment #3)
> > (In reply to Henri Sivonen (not reading bugmail until 2014-01-02)
> > (:hsivonen) from comment #1)
> > > Changing the entity name to make sure non-US English locales pick up the
> > > change.
> > 
> > Is that strictly necessary? This doesn't seem to me like a typo that would
> > cause a mistranslation.
> 
> AIUI whenever we change English strings, even if we believe it wouldn't
> require a change in non-English ones, we need to change the string ID. I've
> run into this before in e.g. bug 854583. Apparently some of the software
> translators use doesn't do well when we change the source strings without
> changing the IDs. I find it very confusing, maybe I still misunderstand.
> Axel?

As Théo mentioned, in that case you were changing the word itself, which could have potential impact on translations. In this case, the word itself isn't changing, so it shouldn't invalidate any translations that were made based on it.

At least, that's how I understand it. Maybe Axel has further insight.
(In reply to Théo Chevalier [:tchevalier] from comment #6)
> You are just fixing a typo in en-US, no need to update the entity, see
> https://developer.mozilla.org/en-US/docs/Making_String_Changes
> 
> In bug 854583 you changed the word, so in this case updating the entity was
> necessary.

Right, but some of the comments there are... confusing. On top of which, I would argue the semantic difference between 'mouse pointer' and 'mouse cursor' is negligible, and so I don't think it was a change that warranted localizer attention (ie I would not have thought any translations would have needed to change).

Anyhow, apparently, r=me with the nit that the entity name should not be changed. :-\

Which still doesn't elucidate whether such a patch could be landed (without localizer havoc) on aurora so we don't misspell Ukrainian in our en-US builds for 28, so leaving needinfo.
(In reply to :Gijs Kruitbosch (Unavailable Dec 19 - Jan 2) from comment #8)
> (In reply to Théo Chevalier [:tchevalier] from comment #6)
> > You are just fixing a typo in en-US, no need to update the entity, see
> > https://developer.mozilla.org/en-US/docs/Making_String_Changes
> > 
> > In bug 854583 you changed the word, so in this case updating the entity was
> > necessary.
> 
> Right, but some of the comments there are... confusing. On top of which, I
> would argue the semantic difference between 'mouse pointer' and 'mouse
> cursor' is negligible, and so I don't think it was a change that warranted
> localizer attention (ie I would not have thought any translations would have
> needed to change).

Many people (myself included) would disagree with you. What seems like a trivial difference in one language can become a huge difference in another, because different words come with different semantic histories.
(In reply to :Gijs Kruitbosch (Unavailable Dec 19 - Jan 2) from comment #8)
> (In reply to Théo Chevalier [:tchevalier] from comment #6)
> > You are just fixing a typo in en-US, no need to update the entity, see
> > https://developer.mozilla.org/en-US/docs/Making_String_Changes
> > 
> > In bug 854583 you changed the word, so in this case updating the entity was
> > necessary.
> 
> Right, but some of the comments there are... confusing. On top of which, I
> would argue the semantic difference between 'mouse pointer' and 'mouse
> cursor' is negligible, and so I don't think it was a change that warranted
> localizer attention (ie I would not have thought any translations would have
> needed to change).
> 

Actually, as French localizer, I can tell that we had the exact same problem as in English: "curseur" vs. "pointeur", so it was worth it.

Here, it is a typo, so all localizers have already fixed it by translating in their language.
We don't translate typos :)
No need to change the entity ID: localizers are supposed to know how to spell Ukrainian in their own language, the current content "Ukranian" was clear enough to identify it as "the language spoken in Ukraine".

Bug 854583: I agree that we needed new IDs there, but I must confess that I didn't know Pootle's behavior as explained in bug 854583 comment 22.

In this case I personally think we can fix the typo in Aurora, eventually send out a mail to dev-l10n to warn about the change.
Comment on attachment 8350883 [details] [diff] [review]
Fix spelling

Yep, please don't change the entity name. According to <http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=charsetMenuAutodet.uk.label>, en-GB and en-ZA aren't affected either -- if they were, we still shouldn't change the entity name but file bugs for these locales.
Attachment #8350883 - Flags: review-
Flags: needinfo?(l10n)
(In reply to Gordon P. Hemsley [:GPHemsley] from comment #3)
> (In reply to Henri Sivonen (not reading bugmail until 2014-01-02)
> (:hsivonen) from comment #1)
> > Changing the entity name to make sure non-US English locales pick up the
> > change.
> 
> Is that strictly necessary? This doesn't seem to me like a typo that would
> cause a mistranslation.

I meant "(non-US) English"--not "non-(US English)". That is, I meant en-* other than en-US.

(In reply to Dão Gottwald [:dao] from comment #12)
> Yep, please don't change the entity name. According to
> <http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=charsetMenuAutodet.
> uk.label>, en-GB and en-ZA aren't affected either -- if they were, we still
> shouldn't change the entity name but file bugs for these locales.

OK.
Attachment #8350883 - Attachment is obsolete: true
Attachment #8355130 - Flags: review?(dao)
Attachment #8355130 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/4ad7f530ece7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Comment on attachment 8355130 [details] [diff] [review]
Fix spelling without renaming key

[Approval Request Comment]
> Bug caused by (feature/regressing bug #): 

Bug 805374

> User impact if declined: 

An incorrectly spelled menu item is visible to the user.

> Testing completed (on m-c, etc.): 

Landed on m-c. No functional testing needed.

> Risk to taking this patch (and alternatives if risky): 

Extremely low-risk.

> String or IDL/UUID changes made by this patch:

One string changes without changing its key. Since this is about incorrect spelling of an English string, the translations don't need to change their strings. English versions other than en-US have not adopted the incorrect string yet.
Attachment #8355130 - Flags: approval-mozilla-aurora?
Attachment #8355130 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.