bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

ftp: URL w/o path should redirect to home dir

VERIFIED FIXED in mozilla0.9.6

Status

()

Core
Networking: FTP
P2
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: jlarsen, Assigned: Andreas Otte)

Tracking

({testcase})

Trunk
mozilla0.9.6
x86
Other
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I wish I could give a public example, but I can't, anyways.
Many ftp sites have user directories that when you goto an ftp site using your
name you login to that directory. 
ftp://username@someftp.com     <--without the ending /
gets changed into 
ftp://username@someftp.com/home/somename
or whatever the ftp server specifies as the home directory for that user.
This works in 4.x and works partially in IE.
(Reporter)

Comment 1

17 years ago
set to networking component :)
Component: Browser-General → Networking
networking:ftp is the correct one.

Wich build are you using (please include in all your bug reports the build ID !)
Assignee: asa → dougt
Component: Networking → Networking: FTP
QA Contact: doronr → benc
I can't find a dupe (I must be too stupid)  -> confirming
Dougt: You can find me on IRC if you need a testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Target Milestone: --- → mozilla0.9.5

Comment 4

17 years ago
reassigning to bbaetz@cs.mcgill.ca.
Assignee: dougt → bbaetz
Yeah, I saw this. Neither dougt or I can find the code which used to handle
this, though.
Status: NEW → ASSIGNED
-> 0.9.6
Priority: -- → P2
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 7

17 years ago
This is possibly related to the discussion in bug 84242, where URL->filesystem 
navigation is not correct.

I need to do a trace, but my guess is that the FTP clients are using some extra 
commands to determine their "current working directory" after a establishing the 
control connection.

Can someone provide a public example or a packet trace?
Keywords: qawanted
Summary: ftp home directory not recognized. → ftp: URL w/o path should redirect to home dir
benc: No. If we did a PWD instead of a CWD, then we could get the 'real' path.
I'm not sure how to tell our consumers that we're redirecting, though. I need to
think about this.
in bug 84242, the new behaviour will be:

ftp://user@host/ -> login dir
ftp://user@host// -> /

See discussion in that bug.

-> andreas
Assignee: bbaetz → andreas.otte
Status: ASSIGNED → NEW
Depends on: 84242
(Assignee)

Comment 10

17 years ago
fix for bug 84242 is checked in, so this is also fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 108723 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
VERIFIED:
Mozilla 1.0, RC1, Win 98.
-qawanted, +testcase
Status: RESOLVED → VERIFIED
Keywords: qawanted → testcase
You need to log in before you can comment on or make changes to this bug.