Closed Bug 952985 Opened 9 years ago Closed 7 years ago

\u{nnnnnn} Unicode code point escapes

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 320500

People

(Reporter: evilpie, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: feature, Whiteboard: [js:p3])

Attachments

(1 file)

I am going to do this.
Attached patch unicode-pointSplinter Review
Support these for strings is relatively easy. For identifier however it looks like we might need to extend the IsIdentifierStart and IsIdentifierPart function to support the whole unicode range. I am not sure if there are valid code points for that outside the 0xffff range, but I would assume so. Or maybe I misunderstood something.
It wouldn't be terribly hard to adapt our vm/make_unicode.py script to also parse DerivedCoreProperties.txt and store a flag for ID_Start - which is what we need here.
I think this would force us to handle the whole Unicode range, instead of just 0 - 0xffff like it's implemented right now. So this really isn't just about parsing some file, and storing a flag. Unless we add a special table just for ID_Start.
I don't have time for this right now.
Assignee: evilpies → nobody
Keywords: feature
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [js:p3]
Support for \u{nnnnnn} escapes in general was added in bug 320500. Making them work in identifiers per comment 1 seems to be covered by bug 917436.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320500
You need to log in before you can comment on or make changes to this bug.