Sliding in Windows Charm while OSK visible on top of Find App Bar will re-appear when selecting "Options"

VERIFIED FIXED in Firefox 28

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: kjozwiak, Assigned: jimm)

Tracking

unspecified
Firefox 29
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox28 verified, firefox29 verified)

Details

(Whiteboard: [beta28] [defect] p=1)

Attachments

(2 attachments)

Reporter

Description

6 years ago
When you have the Find App Bar opened with the OSK visible, sliding in the Windows Charm will correctly dismiss the OSK. If you select "Settings -> Options", the OSK will slide back into view obscuring the "Options" flyout. I can reproduce this issue 100% of the time using the STR listed below.

- Attached a screenshot to illustrate the issue

Steps to reproduce the issue:

1) Open Firefox Metro
2) Open wikipedia.org
3) Slide in the Navigation App Bar and select "Settings -> Find in page"
4) Tap on the text box under the Find App Bar and the OSK should slide into view
5) Once the OSK is visible, slide in the Windows Charm from the right side of the screen
6) Select "Settings -> Options" and you'll notice that the OSK will slide back into view when selecting the "Options" flyout

Current Behaviour:

- If a user slides in the Windows Charm while the OSK is visible when using the Find App Bar, it will slide back into view when selecting the "Options" flyout

Expected Behaviour:

- Once the OSK is hidden and the user slides in the Windows Charm, the OSK shouldn't re-appear when selecting the "Options" flyout

Found the issue using the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-12-22-03-02-04-mozilla-central/
Whiteboard: [triage] [defect] p=0 → [beta28] [defect] p=0
Maybe we are resetting focus back into the browser, which causes the keyboard to appear.
Assignee

Updated

6 years ago
Assignee: nobody → jmathies
Blocks: metrov1it22
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [beta28] [defect] p=0 → [beta28] [defect] p=1
Assignee

Comment 2

6 years ago
In some ways this is desired behavior, for example if you tap the find bar edit to bring up the osk, then hit the windows button twice to flip to the start screen and back, the osk will slide back up when fx opens (with the focus set to the find bar edit).

So I think the fix here is to hide the find bar when a flyout is displayed. We do this for the tab strip and the nav bar already.
Assignee

Comment 3

6 years ago
Posted patch fixSplinter Review
Assignee

Updated

6 years ago
Attachment #8357286 - Flags: review?(mbrubeck)
Attachment #8357286 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/c70641fc5047
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Assignee

Comment 6

6 years ago
Comment on attachment 8357286 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: odd soft keyboard behavior
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8357286 - Flags: approval-mozilla-aurora?
Attachment #8357286 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Kamil, please verify this is fixed in the latest Nightly and Aurora builds.
Flags: needinfo?(kamiljoz)
Reporter

Updated

6 years ago
Depends on: 965684
Reporter

Comment 9

6 years ago
Went through the following verification during iteration #22. Used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-29-00-40-17-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-29-03-06-02-mozilla-central/

- Went through the original test case from comment #0 without any issues
- Ensured that the OSK doesn't overlap the available flyout under "Settings" (Options, Search, About, Permissions)
- Ensured that the OSK appears every single time the search textbox is selected under the Find App Bar
- Ensured that you can dismiss the OSK (Pressing ESC, taping on the website, swiping it away from the top/bottom)
- Ensured when both the OSK & the Find App Bar are visible, pressing the "X" on the Find App Bar will dismiss them both
- Ensured that using the physical keyboard dismisses the OSK without any issues
- Went through all of the above test cases using several variations of snapped view

The issue that was described in comment #0 has been fixed, but found another issue relating to the OSK with the "Options" flyout, created the following bug:
- Bug # Went through the following verification during iteration #22. Used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-29-00-40-17-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-29-03-06-02-mozilla-central/

- Went through the original test case from comment #0 without any issues
- Ensured that the OSK doesn't overlap the available flyout under "Settings" (Options, Search, About, Permissions)
- Ensured that the OSK appears every single time the search textbox is selected under the Find App Bar
- Ensured that you can dismiss the OSK (Pressing ESC, taping on the website, swiping it away from the top/bottom)
- Ensured when both the OSK & the Find App Bar are visible, pressing the "X" on the Find App Bar will dismiss them both
- Ensured that using the physical keyboard dismisses the OSK without any issues
- Went through all of the above test cases using several variations of snapped view

Found the following issue while testing the following bug:
- Bug #965684
Status: RESOLVED → VERIFIED
Flags: needinfo?(kamiljoz)
You need to log in before you can comment on or make changes to this bug.