Closed Bug 953184 Opened 9 years ago Closed 9 years ago

Error message shown if user cancels Import operation in Style Editor

Categories

(DevTools :: Style Editor, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 29

People

(Reporter: sjakthol, Assigned: sjakthol)

Details

(Whiteboard: [good first verify])

Attachments

(2 files)

Attached image error-message.png
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/31.0.1650.63 Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

1. Open Developer Tools
2. Goto Style Editor
3. Press Import...
4. Cancel the file selection


Actual results:

An error "Style sheet could not be loaded" appears.


Expected results:

No error message as user canceled the selection.
Component: Untriaged → Developer Tools: Style Editor
Looking at StyleEditorUtil.jsm it appears that the file argument is null only if user cancelled the file picker dialog so it should be safe to delete that error emission.

File parameter may also be null during automated tests (i.e. when _mockImportFile is defined as a string to a file and an exception occurs during execution of showFilePicker) but that shouldn't be possible during normal operations.

I don't know how to test a lack of "error" event emission reliably so this change has no unittests. Suggestions are welcome.
Attachment #8351508 - Flags: review?(fayearthur)
Comment on attachment 8351508 [details] [diff] [review]
styleeditor-no-error-on-import-cancel.patch

Review of attachment 8351508 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Sami
Attachment #8351508 - Flags: review?(fayearthur) → review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
https://hg.mozilla.org/integration/fx-team/rev/ae1a7cab0b90
Assignee: nobody → sjakthol
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ae1a7cab0b90
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Sami, can you please verify that this is fixed for you in Firefox 29?
Flags: needinfo?(sjakthol)
Whiteboard: [good first verify]
I can confirm this is no longer happening in Firefox 29.
Flags: needinfo?(sjakthol)
Thanks :)
Status: RESOLVED → VERIFIED
Me too.

Site:
https://slashdot.org/my/login

Expected style-sheet. Msg "Style sheet could not be loaded." on style editor for address: https://a.fsdn.com/sd/classic.ssl.css?release_20150309

when visited directly this happened:
"Secure Connection Failed

An error occurred during a connection to a.fsdn.com. The OCSP server experienced an internal error. (Error code: sec_error_ocsp_server_error)"


The problem seems to be related to Firefox trying to load CSS via HTTPS, whilst this could be plugin related, it still happens when Firefox is in safe mode.

(I noticed that when Firefox is in safe mode there are still noscript tags in the HTML, so extensions are not being completely disabled)

HTTPS-Everywhere extension causes same problem when enabled.

This problem seems to have started to happen without any browser updates IIRC.

Other potential problematic plugins:
Force-TLS 4.0.0
Ghostery 5.4.3
Noscript 2.6.9.18
Color toggle
Blacken
context font
document font toggle
betterprivacy
Oops, not me too, I guess this belongs elsewhere.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.