Gifs repeat while they are partially loaded

RESOLVED DUPLICATE of bug 924366
(NeedInfo from)

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 924366
4 years ago
4 years ago

People

(Reporter: Adam, Unassigned, NeedInfo)

Tracking

26 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Go to any page with an animated GIF on the latest firefox


Actual results:

The gif starts playing, then since it is loading and does not yet have all of the gif data, repeats from the beginning again.  It becomes a loop of a gif repeating over and over again, and each repeat it may get a little longer until the entire gif is downloaded.

It is driving me insane watching the same gif again and again because each time it gets a little longer and I have no idea which iteration will be the final one.

Please undo this madness.


Expected results:

The gif should either.  Finish loading, and then play.  OR Play what is loading, BUT DO NOT REPEAT WHILE STILL LOADING!!!

Please, stop the madness. Its so annoying Id rather use chrome..  I cannot believe I just said that. :|
(Reporter)

Updated

4 years ago
Summary: Gifs play while they load now → Gifs repeat while they are partially loaded

Comment 1

4 years ago
Adam,

Please give the URL of a .gif that exhibits the behavior.
Flags: needinfo?(Dragon_Guardian)

Comment 2

4 years ago
FWIW This add-on might help alleviate "the madness" https://addons.mozilla.org/en-US/firefox/addon/gif-delayer/

Updated

4 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core

Comment 3

4 years ago
This is likely a duplicate of bug 924366, and therefore fixed in Firefox 29. Adam, could you try a nightly build (http://nightly.mozilla.org/) and see if you can reproduce the problem?

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924366
You need to log in before you can comment on or make changes to this bug.