Closed Bug 953288 Opened 6 years ago Closed 6 years ago

jank when typing in the url bar

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox27 --- verified
firefox28 --- verified
firefox29 --- verified
fennec 27+ ---

People

(Reporter: blassey, Assigned: jchen)

References

Details

Attachments

(2 files)

Attached video url_jank.mp4
I am seeing this frequently, seems to have gotten worse in the last month or so
Duplicate of this bug: 938148
This may be a variant of bug 919598. Those long "data:image/png" URLs (that show up during the jank) take a long time to draw and make the UI unresponsive. I think we should pre-shorten the URLs before displaying them.
tracking-fennec: ? → 27+
I think a lot of the jank is due to us trying to draw very long URLs in about:home. This patch limits the displayed URL to 1024 characters. I think this is okay because it's for display only and should not affect the actual URL used when the items are used. 1024 is an arbitrary value that seems reasonable, and can be changed.
Attachment #8356198 - Flags: review?(lucasr.at.mozilla)
I thought you meant "URL length" in the textbox, but you mean in the URL lists. We don't even display 1024 chars since they get truncated.
(In reply to Mark Finkle (:mfinkle) from comment #4)
> I thought you meant "URL length" in the textbox, but you mean in the URL
> lists. We don't even display 1024 chars since they get truncated.

Apparently when drawing text, even if most of the text will be truncated, Android still measures the entire text, which can take a long time... *shakes fist at Android*

I thought about limiting the textbox length too, but that'll have more impact on user experience (e.g. the URL will be truncated if the user tries to copy the textbox URL)
Status: NEW → ASSIGNED
Comment on attachment 8356198 [details] [diff] [review]
Limit length of URLs for display (v1)

Review of attachment 8356198 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like a sane thing to try. But I do wonder if this is related to the DB query instead. Let's get this in Nightly and see if improves things in blassey's device.
Attachment #8356198 - Flags: review?(lucasr.at.mozilla) → review+
Dropping a NI for Brad to follow up with tomorrow's nightly or an inbound build if he is feeling adventurous.
Flags: needinfo?(blassey.bugs)
OS: Mac OS X → Android
Hardware: x86 → All
tested an inbound build, much better. Do we want to create another bug to look at DB related jank?
Status: ASSIGNED → NEW
Flags: needinfo?(blassey.bugs)
Status: NEW → ASSIGNED
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #10)
> tested an inbound build, much better. Do we want to create another bug to
> look at DB related jank?

Marking this one as fixed. NI'ing :lucasr for the DB jank question.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(lucasr.at.mozilla)
Resolution: --- → FIXED
Whiteboard: [leave open]
Target Milestone: --- → Firefox 29
Comment on attachment 8356198 [details] [diff] [review]
Limit length of URLs for display (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): New about:home

User impact if declined: Slow response when displaying items containing long URLs

Testing completed (on m-c, etc.): Locally, m-c

Risk to taking this patch (and alternatives if risky): None; simple resource file change

String or IDL/UUID changes made by this patch: None
Attachment #8356198 - Flags: approval-mozilla-beta?
Attachment #8356198 - Flags: approval-mozilla-aurora?
Attachment #8356198 - Flags: approval-mozilla-beta?
Attachment #8356198 - Flags: approval-mozilla-beta+
Attachment #8356198 - Flags: approval-mozilla-aurora?
Attachment #8356198 - Flags: approval-mozilla-aurora+
We should make sure that this data change does not break for large devices in landscape mode such as the Nexus 10. I don't think 1024 characters can be displayed there but it should be verified.
(In reply to Jim Chen [:jchen :nchen] from comment #11)
> (In reply to Brad Lassey [:blassey] (use needinfo?) from comment #10)
> > tested an inbound build, much better. Do we want to create another bug to
> > look at DB related jank?
> 
> Marking this one as fixed. NI'ing :lucasr for the DB jank question.

File a follow-up to investigate any potential DB-related causes?
Flags: needinfo?(lucasr.at.mozilla)
Filled Bug 960005 for follow up investigations. 

As per Brad's comment :
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #10)
> tested an inbound build, much better. Do we want to create another bug to
> look at DB related jank?

and further testing on Nightly 29.0a1 (2014-01-14), Aurora 28.0a1 (2014-01-14) and Beta 27.0b6 I wills et this as verified as I am not facing the lag Brad did.
See Also: → 960005
You need to log in before you can comment on or make changes to this bug.