Closed Bug 953295 Opened 8 years ago Closed 8 years ago

Arrow keys don't work in restore session page

Categories

(SeaMonkey :: Session Restore, defect)

defect
Not set
normal

Tracking

(seamonkey2.24 wontfix, seamonkey2.25 fixed, seamonkey2.26 fixed)

RESOLVED FIXED
seamonkey2.27
Tracking Status
seamonkey2.24 --- wontfix
seamonkey2.25 --- fixed
seamonkey2.26 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

(Keywords: access)

Attachments

(1 file)

After my VM blue screened it offered to restore my previous session. I decided I didn't want to restore the first 10 of my tabs, unfortunately due to poor design all 20 tabs had the same title, so it was almost impossible to keep count. If the down arrow key had been available I could have just hit down arrow and space 10 times in a row.

The arrow keys were disabled when the page was first written because trees didn't originally cancel their arrow key events. This was changed in bug 655004 (after some pestering by yours truly!) and so it is no longer necessary to disable the arrow keys.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8351582 - Flags: review?(philip.chee)
Comment on attachment 8351582 [details] [diff] [review]
Proposed patch

a=me

(should ask stefanh if we need to port Firefox Bug 565024 (accel+click doesn't restore about:sessionrestore entries on OS X)
Attachment #8351582 - Flags: review?(philip.chee) → review+
Pushed comm-central changeset 08b8cae1f27e.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.26
Firefox turned out to have the same problem (bug 950373 for more details).
[Approval Request Comment]
Regression caused by (bug #): 501496
User impact if declined: Loss of keyboard access
Testing completed (on m-c, etc.): Uplifted to c-a
Risk to taking this patch (and alternatives if risky): Very low
String changes made by this patch: None
Comment on attachment 8351582 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 501496
User impact if declined: Loss of keyboard access
Testing completed (on m-c, etc.): Uplifted to c-a
Risk to taking this patch (and alternatives if risky): Very low
String changes made by this patch: None
Attachment #8351582 - Flags: approval-comm-beta?
Comment on attachment 8351582 [details] [diff] [review]
Proposed patch

a=me
Attachment #8351582 - Flags: approval-comm-beta? → approval-comm-beta+
Target Milestone: seamonkey2.26 → seamonkey2.27
I'm still encountering this bug in Firefox 29.0, a few months later.  Should I be?

It is conceivable that there is some interaction with one of my add-ons, such as Session Manager 0.8.1.3 or perhaps Tab Kit 2nd Edition 0.10.0.

----

Remark:
This bug is important to me because often I end up with a few hundred tabs open after a few weeks of use.
This is cluttered and makes the browser sluggish.
The quickest way to kill the tabs that I don't want is to restart the browser and move rapidly through the Restore Session list, using "down arrow" and "space" to identify stale tabs by title.  This is very fast and does not require swapping the page into memory.  But down arrow doesn't do anything for me.
(In reply to Eclecticos from comment #9)
> I'm still encountering this bug in Firefox 29.0, a few months later.  Should
> I be?
Yes, bug 950373 (which I mentioned in comment #4) is the equivalent bug for Firefox and that won't be fixed before the imminent Firefox 30 release (see the comments in that bug for why).
You need to log in before you can comment on or make changes to this bug.