Closed Bug 953317 Opened 6 years ago Closed 6 years ago

File permissions not inherited for Firefox 26 downloads on Windows

Categories

(Toolkit :: Downloads API, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 951028

People

(Reporter: jscher, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

My C drive is configured to allow some access by authenticated domain users and local users, and several folders outside of my Windows user profile folder inherit that permission. Starting in Firefox 26, files saved to the less restricted folders strip the extra permissions; this is visually manifested by a small lock added to the file's icon.

This appears to be related to Bug 919076 "Saved files permissions set incorrectly on Linux and Mac". Although MDN states that the 0600 permission should not affect Windows, that may have changed. ("When PR_CREATE_FILE flag is set and the file is created, these flags define the access permission bits of the newly created file. This feature is currently only applicable on Unix platforms. It is ignored by any other platform but it may apply to other platforms in the future." https://developer.mozilla.org/en-US/docs/PR_Open#Parameters)

Related discussion threads:

SuMo: Fix downloaded files permissions on Windows 7: https://support.mozilla.org/questions/977992

MozillaZine: Downloads getting wrong file permissions on Windows 7: http://forums.mozillazine.org/viewtopic.php?f=23&t=2773631


Actual results:

Local system drive:

Owner permission: same
SYSTEM permission: same
Local Administrators permission: same
Local Users permission: stripped
Domain Authenticated Users permission: stripped

Mapped drive to network share:

Inherited permissions were unmodified


Expected results:

Ideally, files should inherit the permissions of the download location (containing folder) and not have different permissions applied to them, so as to avoid disruption of sharing schemes.
Could you retry with FF27+, because bug 919076 is not fixed in FF26.
Component: Untriaged → Download Manager
Flags: needinfo?(jscher)
Product: Firefox → Toolkit
Good question, Loic. Firefox 27 beta 2 (Portable Edition) behaves identically with Firefox 26 as far as I can tell.
Flags: needinfo?(jscher)
I can confirm this on Windows 7 (64bit) with Nightly (32bit).
Version: 26 Branch → Trunk
This issue seems to be a dublicate of #951028
https://bugzilla.mozilla.org/show_bug.cgi?id=951028

Is there someone who can connect them?
Hi matze112 you are correct and reporter MarkRH has some additional insights in his last post on MozillaZine: http://forums.mozillazine.org/viewtopic.php?p=13269815#p13269815
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951028
You need to log in before you can comment on or make changes to this bug.