Wrong Content-Length for gzip-files in Network Monitor

RESOLVED DUPLICATE of bug 731318

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED DUPLICATE of bug 731318
4 years ago
4 years ago

People

(Reporter: halbart.bernhard+persona, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8351660 [details]
screenshot.png: Wireshark vs. Firefox Network Monitor

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Open the Firefox’s Network Monitor, load a website using gzipped style sheets (e.g. http://www.htlwy.ac.at/homepage/index.php ).


Actual results:

The field “Content-Length” for the gz-file only contains the value of the uncompressed version of the style sheet.


Expected results:

I’d like to have either both displayed, like Wireshark does (see screenshot.png). Or, if it isn’t possible to get the compressed file size, it would be great if at least a hint for the user is added, that only the uncompressed size of the file is displayed.
Since IE, Safari and Chrome display the same (wrong) value, I can’t tell if the webserver delivers a compressed file or not.
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools: Netmonitor
(Reporter)

Updated

4 years ago
Version: 26 Branch → Trunk
Thanks for the report!  I hope we'll address this soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731318
You need to log in before you can comment on or make changes to this bug.