Closed Bug 953598 Opened 7 years ago Closed 7 years ago

Use a system tray Icon to avoid exiting Instantbird when the buddy list is closed

Categories

(Instantbird :: Other, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: florian)

References

Details

(Whiteboard: [0.3-blocking])

Attachments

(2 files, 1 obsolete file)

*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2008-10-26 02:03:00 UTC ***

Create a Tray Icon. Make a SINGLE-click on the tray icon open and close Instabird (like the WinXP volume control, and Google Talk).

(I'm using Windows XP)
*** Original post on bio 151 by Marvin <m513901 AT web.de> at 2008-11-18 15:43:45 UTC ***

A Tray icon would be really great, so instantbird doesn't close everytime the buddy list is closed. It would be good if the buddylist window would "minimize to tray", so if you click the minimize button, the everything exept the tray icon disapears.(Win XP)
Marvin
*** Original post on bio 151 by jyoseph <jyoseph AT gmail.com> at 2009-01-17 05:40:37 UTC ***

Absolutely agree. In my opinion Instantbird should not be closed when the buddy list is closed.
*** Original post on bio 151 by jyoseph <jyoseph AT gmail.com> at 2009-01-17 05:47:56 UTC ***

(In reply to comment #2)
> Absolutely agree. In my opinion Instantbird should not be closed when the buddy
> list is closed.
> 

btw, i'm using the mac version, sorry I forgot to specify.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Create a Tray Icon. SINGLE-click on tray icon opens and closes Instabird. → Create a Tray Icon. SINGLE-click on tray icon opens and closes Instantbird.
Target Milestone: --- → 0.2a1
*** Original post on bio 151 at 2009-03-15 00:03:02 UTC ***

Maybe even a change of the close-window-action via the [x]-button on Windows to "Minimize to tray" instead of shutdown could be considered.  

Some other programs use it the same way (among them Skype,..).
Duplicate of this bug: 953561
*** Original post on bio 151 at 2009-08-02 22:17:51 UTC ***

This wasn't fixed in 0.2a1, changing the target milestone accordingly.

An experimental addon adding this feature is available from:
https://addons.instantbird.org/en-US/instantbird/addon/211
Target Milestone: 0.2a1 → 0.2
*** Original post on bio 151 by deOmega <jahkae AT gmail.com> at 2009-08-29 03:55:56 UTC ***

   (In reply to comment #6)
> This wasn't fixed in 0.2a1, changing the target milestone accordingly.
> 
> An experimental addon adding this feature is available from:
> https://addons.instantbird.org/en-US/instantbird/addon/211

That minimize to tray addon works great for this purpose from my experience.  One would think that this would suffice for a while.
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2009-08-29 10:07:27 UTC ***

(In reply to comment #7)
> That minimize to tray addon works great for this purpose from my experience. 
> One would think that this would suffice for a while.

An add-on does not suffice. Fixing this bug would suffice.
*** Original post on bio 151 by deOmega <jahkae AT gmail.com> at 2009-08-29 12:27:05 UTC ***

(In reply to comment #8)
> (In reply to comment #7)
> > That minimize to tray addon works great for this purpose from my experience. 
> > One would think that this would suffice for a while.
> 
> An add-on does not suffice. Fixing this bug would suffice.

I can understand that.  I realize that even with this addon, there are many needs in such a feature, and I also understand that someone installing the program for the first time, should not have to go searching for an addon to make it functional.
*** Original post on bio 151 by patrickjdempsey <pjdkrunkt AT lycos.com> at 2009-12-09 23:11:28 UTC ***

The problem with the extension is that every other chat client I can think of sends the buddy list to the tray when you press "x" and minimizes it into the taskbar when you press the minimize button.  Closing the program typically requires the user to either use the File menu in the open buddy list or the context menu on the tray icon.  New users will find both the default behavior and the behavior with the extension to be unusual.  Fortunately, Instantbird reloads fast enough that accidentally closing it and reopening it doesn't take too much time.
Whiteboard: [0.2-wanted]
Whiteboard: [0.2-wanted]
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2010-03-09 09:45:32 UTC ***

The last release of instantbird was way back in 2009-03. I assume this product is dead!?

I've moved on to Pidgin, and since it doesn't have video or conference calls, now to Skype. Often, OSS just doesn't deliver the goods...
*** Original post on bio 151 by patrickjdempsey <pjdkrunkt AT lycos.com> at 2010-03-11 01:01:40 UTC ***

@Peter Lairo:  Instantbird 0.2beta1 was released in December of 2009.  The latest nightly builds have great improvements over the beta and are pretty exciting.  You can find the beta here:

http://www.instantbird.com/download-0.2b1.html
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2010-03-11 08:49:35 UTC ***

@patrick: Thanks. The nightly builds at least work now with my Google Talk account, and the options UI is very good.

But there are too many very basic features still missing:

- Doesn't start with the OS by default.
- No UI to set: start with OS
- Minimize to tray still doesn't work (even though there's an add-on that
  provides the code: http://tn123.ath.cx/mintrayr/)
- Red X (in Win7) closes the app instead of minimizing to tray
- Single-click in tray icon to open & close buddy list (this bug)

And then there's the stuff I also need:

- Voice calls
- Video calls
- chat history shown in UI via an ON/OFF toggle button

And the stuff I'd really like to have:

- conference IM
- conference voice calls
- conference video calls
- Avatars

I'm forced to stay with Skype until these features are implemented...
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2010-03-11 11:35:28 UTC ***

(In reply to comment #13)
> there's an add-on that provides the code: http://tn123.ath.cx/mintrayr/)

Unfortunately, the add-on doesn't work with the nightly builds. :-(
*** Original post on bio 151 by patrickjdempsey <pjdkrunkt AT lycos.com> at 2010-03-11 20:38:01 UTC ***

Peter, Bugzilla is not a forum, if you would like to have a discussion you can start a topic at mozillaZine:

http://forums.mozillazine.org/viewforum.php?f=27

Be sure to put the name Instantbird in the title so people know what you are talking about.
*** Original post on bio 151 by SkeleDrew <skeledrew AT gmail.com> at 2010-07-29 21:33:11 UTC ***

(In reply to comment #0)
> Create a Tray Icon. Make a SINGLE-click on the tray icon open and close
> Instabird (like the WinXP volume control, and Google Talk).
> 
> (I'm using Windows XP)

The taskbar/tray icon should be based on the user's current status.
Blocks: 954055
Target Milestone: 0.2 → 1.0
Whiteboard: [0.3-blocking]
Attached patch Patch v1 (obsolete) — Splinter Review
*** Original post on bio 151 as attmnt 577 at 2011-04-07 23:01:00 UTC ***

This contains a straight copy of the XPCOM component of the mintrayr add-on, and a very simplified version of the chrome code of the add-on.

Completely untested (testing is the next step).
Attached patch Patch v1.1Splinter Review
*** Original post on bio 151 as attmnt 578 at 2011-04-08 15:35:00 UTC ***

Same as before, but tested and fixed to work on Windows.
Comment on attachment 8352319 [details] [diff] [review]
Patch v1

*** Original change on bio 151 attmnt 577 at 2011-04-08 15:35:35 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352319 - Attachment is obsolete: true
*** Original post on bio 151 at 2011-04-08 23:48:19 UTC ***

Pushed this as https://hg.instantbird.org/instantbird/rev/26e8020088e0

This fixes the main issue (people closing Instantbird accidentally when they just wanted to get the blist window out of the way) but the behavior is not really satisfying. Anybody wanting to investigate what the "good" behavior would be and to try to implement it is welcome to file another bug (which wouldn't block 0.3).
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: 1.0 → 0.3a2
*** Original post on bio 151 by Paul [sabret00the] <sabret00the AT yahoo.co.uk> at 2011-04-09 10:24:25 UTC ***

(In reply to comment #19)
I'll play with it in today's nightly but how is good/bad behaviour defined?
Depends on: 954183
Depends on: 954184
*** Original post on bio 151 at 2011-04-10 20:25:56 UTC ***

(In reply to comment #20)
> (In reply to comment #19)
> I'll play with it in today's nightly but how is good/bad behaviour defined?

Figuring this out is part of the job ;)
See comment #19.
*** Original post on bio 151 by Paul [sabret00the] <sabret00the AT yahoo.co.uk> at 2011-04-10 20:31:15 UTC ***

(In reply to comment #21)
> (In reply to comment #20)
> > (In reply to comment #19)
> > I'll play with it in today's nightly but how is good/bad behaviour defined?
> 
> Figuring this out is part of the job ;)
> See comment #19.
Glad to hear it, filed bug 954183 (bio 749) and 750 to fix the main problems I found which would ultimately add usability. Currently there's a few things that I envision would be good (i.e. double click should hide/unhide buddy list), but there's just not enough function as of yet.
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2011-04-10 21:16:32 UTC ***

(In reply to comment #22)
> double click should hide/unhide buddy list

Isn't that what THIS bug is about?

"SINGLE-click on tray icon opens and closes Instantbird"

Isn't "opening/closing Instantbird" the same thing as "hiding/unhiding the buddy list"? Surely "opening/closing Instantbird" does not mean launching and exiting the program!?
*** Original post on bio 151 by Paul [sabret00the] <sabret00the AT yahoo.co.uk> at 2011-04-11 08:56:12 UTC ***

(In reply to comment #23)
> (In reply to comment #22)
> > double click should hide/unhide buddy list
> 
> Isn't that what THIS bug is about?
> 
> "SINGLE-click on tray icon opens and closes Instantbird"
> 
> Isn't "opening/closing Instantbird" the same thing as "hiding/unhiding the
> buddy list"? Surely "opening/closing Instantbird" does not mean launching and
> exiting the program!?

Occasionally the devs will decide to implement something in a more bare-bones fashion and defer the rest to followup bugs. On this occasion, it was deemed better for the project that this was implemented in it's current fashion. If you feel that there is any other usability/functionality missing, please fill free to file the relevant followup bugs setting them to block this one.
*** Original post on bio 151 at 2011-04-11 09:06:00 UTC ***

(In reply to comment #23)
> (In reply to comment #22)
> > double click should hide/unhide buddy list
> 
> Isn't that what THIS bug is about?

I read again the initial description here, and it seems I took more into account the comment 1 to 7 while deciding what to do for 0.3. I'm sorry if the changes made here are not what you expected of this bug. The recently filed bug 954183 (bio 749) seems to be aligned with your original expectations. I'm editing this bug's summary to reflect what we actually fixed here.
Summary: Create a Tray Icon. SINGLE-click on tray icon opens and closes Instantbird. → Use a system tray Icon to avoid exiting Instantbird when the buddy list is closed
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2011-04-11 11:59:28 UTC ***

(In reply to comment #25)
> (In reply to comment #23)
> > (In reply to comment #22)
> > > double click should hide/unhide buddy list
> > 
> > Isn't that what THIS bug is about?
> 
> The recently filed bug 954183 (bio 749) seems to be aligned with your original expectations.

That bug's summary is: "nuke GetFontCache API's". What does that have to do with (single or double) clicking on the tray icon to open and close the buddy list?

And I still don't understand, from the comments here, what was changed by this bug.
*** Original post on bio 151 at 2011-04-11 14:35:30 UTC ***

(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #23)
> > The recently filed bug 954183 (bio 749) seems to be aligned with your original expectations.
> That bug's summary is: "nuke GetFontCache API's". What does that have to do
> with (single or double) clicking on the tray icon to open and close the buddy
> list?
You're looking at the Mozilla bug 954183 (bio 749), not the Instantbird bug 954183 (bio 749).

> And I still don't understand, from the comments here, what was changed by this
> bug.
This bug has implemented minimize to tray support for Instantbird. By default, when a user hits the x button in Instantbird, it will be minimized to tray, as many users expect an IM program to do (as gathered from user feedback via email and IRC).  Alternately, one can choose to have Instantbird never minimize to tray, minimize to tray for minimize only or both minimize to tray for minimizing or closing Instantbird.

If there are any other unresolved issues not covered by this, please file a follow up bug and block this bug. Please check out bug 954183 (bio 749) and bug 954184 (bio 750) first (or anything else this bug depends on).
*** Original post on bio 151 by Peter Lairo <Peter AT Lairo.com> at 2011-04-11 14:58:28 UTC ***

Neither of those bugs[1,2] address what this bug was originally intended to fix, namely, to open and close the buddy list when clicking and/or double-clicking the try icon.

NB: If you are going to redefine the goals of the bugs I report and cause me extra work to unscramble what was done, and to file new bugs to achieve what I had already articulated, then I just don't have the time and energy to participate here anymore.

[1] Bug 954183 (bio 749) - Tray Icon should persist even when Buddy List is open 

[2] Bug 954184 (bio 750) - Expand Tray Icon context menu with commonly used actions
*** Original post on bio 151 by Paul [sabret00the] <sabret00the AT yahoo.co.uk> at 2011-04-11 15:09:49 UTC ***

(In reply to comment #28)
> Neither of those bugs[1,2] address what this bug was originally intended to
> fix, namely, to open and close the buddy list when clicking and/or
> double-clicking the try icon.
> 
> NB: If you are going to redefine the goals of the bugs I report and cause me
> extra work to unscramble what was done, and to file new bugs to achieve what I
> had already articulated, then I just don't have the time and energy to
> participate here anymore.
> 
> [1] Bug 954183 (bio 749) - Tray Icon should persist even when Buddy List is open 
> 
> [2] Bug 954184 (bio 750) - Expand Tray Icon context menu with commonly used actions

Sometimes things like this happen. I assure you that at the time of this bug being patched, Flo at no point said to himself or anyone else for that matter that his intention was to short change the bug. In reality the bug as you originally posted it has been at least 50% implemented. Sometimes for the coders that actually patch the bugs it's far easier to implement a foundation and build on that. As you can clearly see, the child bugs have been filed and as a project Instantbird will endeavour to deliver the best possible user experience to it's users. 

I would like to personally reiterate that the methodology of the implementation of this bug wasn't a personal thing against you. Nor was it intended to offend you. You've stated that neither bug 954183 (bio 749) nor bug 954184 (bio 750) add the functionality that you feel is missing from this bug. I can only once again request that anything that's left out.
*** Original post on bio 151 at 2011-04-11 15:37:54 UTC ***

(In reply to comment #28)
> Neither of those bugs[1,2] address what this bug was originally intended to
> fix, namely, to open and close the buddy list when clicking and/or
> double-clicking the try icon.
> [1] Bug 954183 (bio 749) - Tray Icon should persist even when Buddy List is open 
> [2] Bug 954184 (bio 750) - Expand Tray Icon context menu with commonly used actions

From what I can tell bug 954183 (bio 749) would accomplish thisl, or perhaps I'm not understanding what you want at all.

From your explaination I'm inferring that you want 1. tray icon always visible; 2. want to be able to double click that tray icon to minimize the buddy list; 3. want to be able to double click that tray icon to restore the buddy list.

3 has been implemented as part of this bug (once the buddy list is minimized).
1 is bug 954183 (bio 749).
2 is argubly part of bug 954183 (bio 749), not but explicitly stated (feel free to comment on it).

If this understanding is WRONG then please explain how specifically this differs.

One final question, is there any difference to  "open and close" and "minimize and restore"? The proper Windows UX is to "minimize" to the tray, not just to close/disappear from my experience.
*** Original post on bio 151 as attmnt 586 at 2011-04-14 20:16:00 UTC ***

I'm attaching the work-in-progress I had of an implementation based on Songbird's code from http://publicsvn.songbirdnest.com/client/trunk/extensions/systray/

I had to give up because the C++ code doesn't compile with Mozilla2 and it seemed non trivial to fix.

I'm attaching it so that it doesn't get lost. Maybe someday it will be useful. (It seems clokep has found a version updated for Firefox 4 of a mostly similar code at http://dev.salsitasoft.com/trac/webrunner/browser/)
*** Original post on bio 151 by deOmega <jahkae AT gmail.com> at 2011-08-27 16:04:35 UTC ***

Thank you so much. :)
You need to log in before you can comment on or make changes to this bug.