Closed Bug 953661 Opened 6 years ago Closed 6 years ago

[Accessibility] "Connected Connecting Disconnected Disconnecting" are shown on the account item

Categories

(Instantbird :: Account manager, defect, P5, minor)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: romain, Assigned: florian)

References

Details

(Whiteboard: accessibility)

Attachments

(1 file)

*** Original post on bio 215 at 2009-08-14 16:57:00 UTC ***

We might want to refresh the richlistitem.
To check this behavior we can also use accprobe on windows:
http://www.eclipse.org/actf/downloads/tools/accprobe/

<pvagner> I am not sure if these labels fire some kind of stateChange event. If yes then we can update the list as appropriate.
*** Original post on bio 215 at 2009-08-19 00:23:48 UTC ***

I tend to think this is a XBL or screen reader issue.
The norm defines that display: none are not shown, and this is not a refresh problem, since the accessible-name is refreshed when the alias change.
Possible solutions:

- add IDs on each item and define aria-describedby [these items minus the status]
    -> this solution is dirty
- Give a "static" name to the element (the account name for example)
    -> this solution may not be appreciated by people who use screen readers..
- define a single label that is updated ...
    -> This is weird
- disable each item one by one except the real one, with aria-hidden="true"


I really don't know what to do with this bug, The easier solution would be to give a static name, and if the person wants more information then s?he would crawl in the node itself.

I have looked at the documentation of aria, there are a lot of things (which are handled by default by Mozilla), there is nothing interesting for us there.
Priority: -- → P5
Whiteboard: accessibility
*** Original post on bio 215 as attmnt 272 at 2010-02-28 12:50:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Duplicate of this bug: 953854
*** Original post on bio 215 at 2010-05-05 21:49:45 UTC ***

The reason why this happens has been explained in bug 953853 (bio 412) comment 0 (Thanks Marco!).

Now that we know what's going on here, it's easy to fix: http://hg.instantbird.org/instantbird/rev/bca57c99afd7
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.2
*** Original post on bio 215 by Marco Zehe (:MarcoZ) <marco.zehe AT googlemail.com> at 2010-05-10 08:52:43 UTC ***

Unfortunately, with the fix, now only the account name is spoken. It would still be useful to have the actual status (connected, disconnected) in there as well.
*** Original post on bio 215 at 2010-05-10 09:18:08 UTC ***

When I explore the accessible tree, I see that, inside the list item, the label containing the status is accessible. Isn't this label read?
*** Original post on bio 215 by Marco Zehe (:MarcoZ) <marco.zehe AT googlemail.com> at 2010-05-10 09:28:48 UTC ***

Yes, it is with object navigation in NVDA and possibly similar techniques in Orca. It's just not automatically read, and unlike the other items inside, doesn't have a tab stop. That *might* be an option, make this a separate tab stop so it is more easily discoverable.
You need to log in before you can comment on or make changes to this bug.